summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 15:19:09 +0200
committerPiotr Rogoża2015-06-14 15:19:09 +0200
commit63f01012cc472a2fdd2726d462fdd41b645afb59 (patch)
tree555420cbc44b9b90f865c8228253a2e83340112f
downloadaur-63f01012cc472a2fdd2726d462fdd41b645afb59.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c692dadd90ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dialog-doc
+ pkgdesc = Samples for the dialog, a tool to display dialog boxes from shell scripts
+ pkgver = 1.2_20130928
+ pkgrel = 1
+ url = http://invisible-island.net/dialog/
+ arch = any
+ license = GPL
+ depends = sh
+ depends = bash
+ depends = dialog>=1.1_20110118
+ source = ftp://invisible-island.net/dialog/dialog-1.2-20130928.tgz
+ source = ftp://invisible-island.net/dialog/dialog-1.2-20130928.tgz.asc
+ sha256sums = 6fcf8daa50335e4d08da9f4f5ea5e1025efe84c3a719a56e871eb83ed0fd2b4c
+ sha256sums = SKIP
+
+pkgname = dialog-doc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87fc89697c50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh et:
+
+pkgname=dialog-doc
+_pkgname=dialog
+pkgver=1.2_20130928
+_pkgver=${pkgver/_/-}
+pkgrel=1
+pkgdesc="Samples for the dialog, a tool to display dialog boxes from shell scripts"
+arch=('any')
+url="http://invisible-island.net/dialog/"
+license=('GPL')
+depends=('sh' 'bash' 'dialog>=1.1_20110118')
+source=(
+ftp://invisible-island.net/${_pkgname}/${_pkgname}-$_pkgver.tgz
+ftp://invisible-island.net/${_pkgname}/${_pkgname}-$_pkgver.tgz.asc
+)
+# ftp://invisible-island.net/dialog/
+
+package() {
+ cd "${srcdir}"/${_pkgname}-${_pkgver}/samples/
+
+ install -dm755 ${pkgdir}/usr/share/doc/${_pkgname}/samples
+
+ # search for executeables files
+ find -maxdepth 1 -type f -perm +111 -print | \
+ xargs -I{} cp {} ${pkgdir}/usr/share/doc/$_pkgname/samples/
+
+ for i in README report-* setup-* testdata-8bit textbox.txt whiptail.rc \
+ checklist9.txt; do
+ install -Dm 644 $i ${pkgdir}/usr/share/doc/$_pkgname/samples
+ done
+}
+sha256sums=('6fcf8daa50335e4d08da9f4f5ea5e1025efe84c3a719a56e871eb83ed0fd2b4c'
+ 'SKIP')