summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2016-04-18 23:28:48 +0200
committerPiotr Rogoża2016-04-18 23:28:48 +0200
commit69d72e3838e708aa41840182643c110f0eb47c1f (patch)
tree73fe2b6ffcc0fdfdc51445be7c75a4c0396a41cc
parent63f01012cc472a2fdd2726d462fdd41b645afb59 (diff)
downloadaur-69d72e3838e708aa41840182643c110f0eb47c1f.tar.gz
Upgraded to 1.3-20160209
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c692dadd90ef..abc0d1f9e006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Apr 18 21:27:51 UTC 2016
pkgbase = dialog-doc
pkgdesc = Samples for the dialog, a tool to display dialog boxes from shell scripts
- pkgver = 1.2_20130928
+ pkgver = 1.3_20160209
pkgrel = 1
url = http://invisible-island.net/dialog/
arch = any
license = GPL
depends = sh
depends = bash
- depends = dialog>=1.1_20110118
- source = ftp://invisible-island.net/dialog/dialog-1.2-20130928.tgz
- source = ftp://invisible-island.net/dialog/dialog-1.2-20130928.tgz.asc
- sha256sums = 6fcf8daa50335e4d08da9f4f5ea5e1025efe84c3a719a56e871eb83ed0fd2b4c
+ depends = dialog
+ source = ftp://invisible-island.net/dialog/dialog-1.3-20160209.tgz
+ source = ftp://invisible-island.net/dialog/dialog-1.3-20160209.tgz.asc
+ sha256sums = 0314f7f2195edc58e7567a024dc1d658c2f8ea732796d8fa4b4927df49803f87
sha256sums = SKIP
pkgname = dialog-doc
diff --git a/PKGBUILD b/PKGBUILD
index 87fc89697c50..dabd493d8a24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,33 @@
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# vim:set ts=2 sw=2 et ft=sh et:
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
pkgname=dialog-doc
-_pkgname=dialog
-pkgver=1.2_20130928
+pkgver=1.3_20160209
_pkgver=${pkgver/_/-}
pkgrel=1
pkgdesc="Samples for the dialog, a tool to display dialog boxes from shell scripts"
arch=('any')
url="http://invisible-island.net/dialog/"
license=('GPL')
-depends=('sh' 'bash' 'dialog>=1.1_20110118')
+depends=(sh bash dialog)
source=(
-ftp://invisible-island.net/${_pkgname}/${_pkgname}-$_pkgver.tgz
-ftp://invisible-island.net/${_pkgname}/${_pkgname}-$_pkgver.tgz.asc
+ftp://invisible-island.net/dialog/dialog-$_pkgver.tgz
+ftp://invisible-island.net/dialog/dialog-$_pkgver.tgz.asc
)
+sha256sums=('0314f7f2195edc58e7567a024dc1d658c2f8ea732796d8fa4b4927df49803f87'
+ 'SKIP')
# ftp://invisible-island.net/dialog/
-
+validpgpkeys=(C52048C0C0748FEE227D47A2702353E0F7E48EDB) #Thomas Dickey <dickey@invisible-island.net>
package() {
- cd "${srcdir}"/${_pkgname}-${_pkgver}/samples/
+ cd "${srcdir}"/dialog-${_pkgver}/samples/
- install -dm755 ${pkgdir}/usr/share/doc/${_pkgname}/samples
+ install -dm755 ${pkgdir}/usr/share/doc/dialog/samples
# search for executeables files
- find -maxdepth 1 -type f -perm +111 -print | \
- xargs -I{} cp {} ${pkgdir}/usr/share/doc/$_pkgname/samples/
+ find -maxdepth 1 -type f -executable -print | \
+ xargs -I{} cp {} ${pkgdir}/usr/share/doc/dialog/samples/
for i in README report-* setup-* testdata-8bit textbox.txt whiptail.rc \
checklist9.txt; do
- install -Dm 644 $i ${pkgdir}/usr/share/doc/$_pkgname/samples
+ install -Dm 644 $i ${pkgdir}/usr/share/doc/dialog/samples
done
}
-sha256sums=('6fcf8daa50335e4d08da9f4f5ea5e1025efe84c3a719a56e871eb83ed0fd2b4c'
- 'SKIP')