summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-11-03 08:56:52 +0000
committerBioArchLinuxBot2022-11-03 08:56:52 +0000
commit040d0ff8e805d681c75fd12b3c07e2d91a488478 (patch)
treeb9335e9697820ad42f9e3254d0fe9cad1ce1f969
parentcb2196fc99092013ab43a91019067ddae29bebed (diff)
downloadaur-040d0ff8e805d681c75fd12b3c07e2d91a488478.tar.gz
[lilac] updated to 2.0.15-2
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD65
-rw-r--r--diamond-4.0.41.tar.gzbin193663 -> 0 bytes
-rw-r--r--diamond.service10
4 files changed, 43 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcb62f15337b..f9b01bec2406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,14 @@
pkgbase = diamond
- pkgdesc = Daemon that collects system metrics and publishes them to graphite and others
- pkgver = 4.0.515
- pkgrel = 4
- url = https://github.com/python-diamond/Diamond
- arch = any
- license = mit
- makedepends = python2
- depends = python2
- depends = python
- optdepends = python2-psycopg2: Postgresql collector
- optdepends = python2-pysensors: LMSensors collector
- optdepends = libvirt-python: LibvirtKVM collector
- optdepends = python2-yaml: PuppetAgent collector
- backup = etc/diamond/diamond.conf
- source = https://pypi.python.org/packages/0c/b6/4c58a8a1111c138fbed9e65dd918be706af8abd07bb5e8fe3ddfb453d899/diamond-4.0.515.tar.gz
- source = https://archive.org/download/diamond_201801/diamond.service
- md5sums = 9ef6c5203e098da10aa0d90b344a49da
- md5sums = 4294f34a8a4644c28788b997dcb4ba22
+ pkgdesc = DIAMOND is a sequence aligner for protein and translated DNA searches, designed for high performance analysis of big sequence data https://doi.org/10.1038/s41592-021-01101-x
+ pkgver = 2.0.15
+ pkgrel = 2
+ url = https://github.com/bbuchfink/diamond
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = gcc-libs
+ depends = zlib
+ source = diamond-2.0.15.tar.gz::https://github.com/bbuchfink/diamond/archive/v2.0.15.tar.gz
+ sha256sums = cc8e1f3fd357d286cf6585b21321bd25af69aae16ae1a8f605ea603c1886ffa4
pkgname = diamond
-
diff --git a/PKGBUILD b/PKGBUILD
index a0917fc6c13b..3d09e233ff84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
-# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com >
-# Maintainer: Uzerus < szymonscholz at gmail.com >
-# Contributor: Justin Dray <justin@dray.be>
-# Contributor: Augusto F. Hack <hack.augusto@gmail.com>
+# Maintainer: Bipin Kumar <bipin@ccmb.res.in>
+# shellcheck disable=2034
+# shellcheck disable=2148
pkgname=diamond
-pkgver=4.0.515
-pkgrel=4
-pkgdesc="Daemon that collects system metrics and publishes
-them to graphite and others"
-arch=('any')
-url="https://github.com/python-diamond/Diamond"
-license=('mit')
-depends=('python2' 'python')
-makedepends=('python2')
-optdepends=('python2-psycopg2: Postgresql collector'
- 'python2-pysensors: LMSensors collector'
- 'libvirt-python: LibvirtKVM collector'
- 'python2-yaml: PuppetAgent collector')
-backup=(etc/diamond/diamond.conf)
-source=("https://pypi.python.org/packages/0c/b6/4c58a8a1111c138fbed9e65dd918be706af8abd07bb5e8fe3ddfb453d899/${pkgname}-${pkgver}.tar.gz"
- "https://archive.org/download/${pkgname}_201801/${pkgname}.service")
-md5sums=('9ef6c5203e098da10aa0d90b344a49da'
- '4294f34a8a4644c28788b997dcb4ba22')
+pkgver=2.0.15
+pkgrel=2
+pkgdesc="DIAMOND is a sequence aligner for protein and translated DNA searches, designed for high performance analysis of big sequence data https://doi.org/10.1038/s41592-021-01101-x"
+arch=('x86_64')
+url="https://github.com/bbuchfink/diamond"
+license=('GPL3')
+depends=('gcc-libs' 'zlib')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bbuchfink/diamond/archive/v$pkgver.tar.gz")
+sha256sums=('cc8e1f3fd357d286cf6585b21321bd25af69aae16ae1a8f605ea603c1886ffa4')
+prepare() {
+ # shellcheck disable=2154
+ mkdir -p "$srcdir"/diamond-$pkgver/build
+}
-package() {
- cd "$srcdir/diamond-${pkgver}"
+build() {
+ cd "$srcdir"/diamond-$pkgver/build
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
- install -D -m644 "$srcdir/diamond.service" "$pkgdir/usr/lib/systemd/system/diamond.service"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- rm "$pkgdir/etc/diamond/diamond.conf.example.windows"
- rm -rf "$pkgdir/etc/diamond/collectors"
- rm -rf "$pkgdir/etc/diamond/handlers"
- rm -rf "$pkgdir/usr/share/diamond/user_scripts"
- mv "$pkgdir/etc/diamond/diamond.conf.example" "$pkgdir/etc/diamond/diamond.conf"
+ make
+}
+
+package() {
+ cd "$srcdir"/diamond-$pkgver/build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+ # shellcheck disable=2154
+ make DESTDIR="$pkgdir" install
+}
diff --git a/diamond-4.0.41.tar.gz b/diamond-4.0.41.tar.gz
deleted file mode 100644
index 37f0d14e4ea4..000000000000
--- a/diamond-4.0.41.tar.gz
+++ /dev/null
Binary files differ
diff --git a/diamond.service b/diamond.service
deleted file mode 100644
index 144d7bcc909b..000000000000
--- a/diamond.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Diamond daemon
-After=network.target
-
-[Service]
-ExecStart=/usr/bin/diamond --foreground
-TimeoutStopSec=2
-
-[Install]
-WantedBy=multi-user.target