summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2020-04-06 10:06:44 +0200
committerMichal Wojdyla2020-04-06 10:06:44 +0200
commitcb2196fc99092013ab43a91019067ddae29bebed (patch)
treeb4a4c9f02c51d3266839c1b1ed11cf50ae4000ed
parentb8d757534f58f3ba736f995f3d46ae3c3beb0d49 (diff)
downloadaur-cb2196fc99092013ab43a91019067ddae29bebed.tar.gz
fix pkgbuild, had empty makedepends which prevented building package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9240bec9996..fcb62f15337b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = diamond
pkgdesc = Daemon that collects system metrics and publishes them to graphite and others
pkgver = 4.0.515
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/python-diamond/Diamond
arch = any
license = mit
+ makedepends = python2
depends = python2
depends = python
optdepends = python2-psycopg2: Postgresql collector
diff --git a/PKGBUILD b/PKGBUILD
index 14070e1a58b5..a0917fc6c13b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
+# Maintainer: Michal Wojdyla < micwoj9292 at gmail dot com >
# Maintainer: Uzerus < szymonscholz at gmail.com >
# Contributor: Justin Dray <justin@dray.be>
# Contributor: Augusto F. Hack <hack.augusto@gmail.com>
pkgname=diamond
pkgver=4.0.515
-pkgrel=3
+pkgrel=4
pkgdesc="Daemon that collects system metrics and publishes
them to graphite and others"
arch=('any')
url="https://github.com/python-diamond/Diamond"
license=('mit')
depends=('python2' 'python')
-makedepends=('')
+makedepends=('python2')
optdepends=('python2-psycopg2: Postgresql collector'
'python2-pysensors: LMSensors collector'
'libvirt-python: LibvirtKVM collector'
@@ -35,5 +36,4 @@ package() {
mv "$pkgdir/etc/diamond/diamond.conf.example" "$pkgdir/etc/diamond/diamond.conf"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
-}
-
+} \ No newline at end of file