summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-09-25 00:01:59 -0300
committerDaniel Bermond2024-09-25 00:01:59 -0300
commit0ada70559aba7b0c3fec7c7caf02ed997749804b (patch)
tree57a48d880ee05165acdcd6e715c36790f71f070f
parentb3e017392b3a2d58f97fb2bb5ebb31e11d379126 (diff)
downloadaur-0ada70559aba7b0c3fec7c7caf02ed997749804b.tar.gz
Update to version 1.5.1
-rw-r--r--.SRCINFO12
-rw-r--r--010-diamond-editor-do-not-copy-cs-libs.patch2
-rw-r--r--PKGBUILD14
-rw-r--r--diamond-editor.desktop1
4 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77faa4c27941..e1bdd4e3fad4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = diamond-editor
pkgdesc = Compact text editor designed for programmers
- pkgver = 1.4.1
+ pkgver = 1.5.1
pkgrel = 1
url = https://www.copperspice.com/
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = cmake
depends = sh
depends = copperspice
depends = hunspell
- source = https://github.com/copperspice/diamond/archive/diamond-1.4.1/diamond-editor-1.4.1.tar.gz
+ source = https://github.com/copperspice/diamond/archive/diamond-1.5.1/diamond-editor-1.5.1.tar.gz
source = 010-diamond-editor-do-not-copy-cs-libs.patch
source = diamond-editor.desktop
source = diamond-editor.sh
- sha256sums = 1dcbe0a55593bdcaa619bb45c509300491970d8e6c9ce3b0cb801577ce54d8ce
- sha256sums = e1fad1a3ea74dd9e780e5586964d9e69b4f4be2d2380dc771f52eac44f9e76ba
- sha256sums = e114cad024aa5d6768bd50fabe51c311e37a4a7969382ace8c16878a06b824e4
+ sha256sums = 3502ee9b82793e411fc17c178da212843be0db0e5a3335f1b0c710f019c81529
+ sha256sums = a5c13e576e84922dd7508bb65721839be79f0e82c16729f82cb43a915cec0640
+ sha256sums = 1978034fc2878be60254b8b0dca5ed9c7661a60f825375014843b91ec40fc48d
sha256sums = 16f8c39d44c7dfcf9784a6b0414af4aa266a67de10e17bffb6fd5ea43a95e48a
pkgname = diamond-editor
diff --git a/010-diamond-editor-do-not-copy-cs-libs.patch b/010-diamond-editor-do-not-copy-cs-libs.patch
index cbd5c1c8045f..4ec480005512 100644
--- a/010-diamond-editor-do-not-copy-cs-libs.patch
+++ b/010-diamond-editor-do-not-copy-cs-libs.patch
@@ -1,6 +1,6 @@
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -217,17 +217,3 @@ if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
+@@ -231,17 +231,3 @@ if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
else()
install(TARGETS Diamond DESTINATION .)
endif()
diff --git a/PKGBUILD b/PKGBUILD
index 75e6f7c64cf6..b9d79276d8bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=diamond-editor
-pkgver=1.4.1
+pkgver=1.5.1
pkgrel=1
pkgdesc='Compact text editor designed for programmers'
arch=('x86_64')
url='https://www.copperspice.com/'
-license=('GPL2')
+license=('GPL-2.0-only')
depends=('sh' 'copperspice' 'hunspell')
makedepends=('cmake')
source=("https://github.com/copperspice/diamond/archive/diamond-${pkgver}/${pkgname}-${pkgver}.tar.gz"
'010-diamond-editor-do-not-copy-cs-libs.patch'
'diamond-editor.desktop'
'diamond-editor.sh')
-sha256sums=('1dcbe0a55593bdcaa619bb45c509300491970d8e6c9ce3b0cb801577ce54d8ce'
- 'e1fad1a3ea74dd9e780e5586964d9e69b4f4be2d2380dc771f52eac44f9e76ba'
- 'e114cad024aa5d6768bd50fabe51c311e37a4a7969382ace8c16878a06b824e4'
+sha256sums=('3502ee9b82793e411fc17c178da212843be0db0e5a3335f1b0c710f019c81529'
+ 'a5c13e576e84922dd7508bb65721839be79f0e82c16729f82cb43a915cec0640'
+ '1978034fc2878be60254b8b0dca5ed9c7661a60f825375014843b91ec40fc48d'
'16f8c39d44c7dfcf9784a6b0414af4aa266a67de10e17bffb6fd5ea43a95e48a')
prepare() {
@@ -27,12 +27,12 @@ build() {
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/opt/diamond-editor' \
-Wno-dev
- make -C build
+ cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
- mkdir -p "$pkgdir"{/opt/diamond-editor/{platforms,printerdrivers},/usr/share/pixmaps}
+ install -d -m755 "$pkgdir"{/opt/diamond-editor/{platforms,printerdrivers},/usr/share/pixmaps}
install -D -m755 diamond-editor.sh "${pkgdir}/usr/bin/diamond-editor"
install -D -m644 diamond-editor.desktop -t "${pkgdir}/usr/share/applications"
ln -s ../../../opt/diamond-editor/diamond.png "${pkgdir}/usr/share/pixmaps/diamond-editor.png"
diff --git a/diamond-editor.desktop b/diamond-editor.desktop
index 689f1d27a89f..1242c803a86d 100644
--- a/diamond-editor.desktop
+++ b/diamond-editor.desktop
@@ -5,6 +5,7 @@ Comment=Compact editor designed for programmers
Path=/usr/bin
Exec=diamond-editor
Icon=diamond-editor
+StartupWMClass=Diamond Editor
Terminal=false
StartupNotify=false
Type=Application