summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-01 09:37:38 +0800
committerzxp198210052024-03-01 09:37:38 +0800
commit6d466bf19c9be769af8b85ef570810daf62d85b4 (patch)
tree6581341f76cec86f46dc25047842bf273b1196d9
parent96fbb8e7e874ad443d36bea2bbd58cef32f8d565 (diff)
downloadaur-6d466bf19c9be769af8b85ef570810daf62d85b4.tar.gz
update to 2.7.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--dicionario.js.sh3
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5af96ca503a..4bb7a5b6ee1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = dicionario.js-bin
pkgdesc = Simple dictionary in which you record your own words.
- pkgver = 2.7.2
- pkgrel = 3
+ pkgver = 2.7.5
+ pkgrel = 1
url = https://github.com/ArthurLobopro/dicionario.js
arch = x86_64
license = MIT
- depends = electron26
+ depends = electron28
depends = nodejs
- provides = dicionario.js=2.7.2
+ provides = dicionario.js=2.7.5
conflicts = dicionario.js
- source = dicionario.js-2.7.2.deb::https://github.com/ArthurLobopro/dicionario.js/releases/download/v2.7.2/dicionario.js_2.7.2_amd64.deb
+ source = dicionario.js-2.7.5.deb::https://github.com/ArthurLobopro/dicionario.js/releases/download/v2.7.5/dicionario.js_2.7.5_amd64.deb
source = dicionario.js.sh
- sha256sums = 7908055fc91c0e6953563694f0167ae8e1962ae19cf6ccaeaabcc32147241acc
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 354d3d518cb64f07dbadb9989dfc43702f234c0fb2e330822b97fb36215b033a
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = dicionario.js-bin
diff --git a/PKGBUILD b/PKGBUILD
index 65753ace7502..c76bd9fc7354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=dicionario.js-bin
-pkgver=2.7.2
-_electronversion=26
-pkgrel=3
+pkgver=2.7.5
+_electronversion=28
+pkgrel=1
pkgdesc="Simple dictionary in which you record your own words."
arch=('x86_64')
url="https://github.com/ArthurLobopro/dicionario.js"
@@ -17,14 +17,14 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('7908055fc91c0e6953563694f0167ae8e1962ae19cf6ccaeaabcc32147241acc'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+sha256sums=('354d3d518cb64f07dbadb9989dfc43702f234c0fb2e330822b97fb36215b033a'
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.zst"
+ bsdtar -xf "${srcdir}/data."*
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/dicionario.js.sh b/dicionario.js.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/dicionario.js.sh
+++ b/dicionario.js.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then