summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-06 13:25:51 +0800
committerzxp198210052024-02-06 13:25:51 +0800
commit96fbb8e7e874ad443d36bea2bbd58cef32f8d565 (patch)
tree8930f2b4204fea1fba35ee36060e0e3a9404110f
parent2edceb3b4925636eb77eba38598f47e3c981378f (diff)
downloadaur-96fbb8e7e874ad443d36bea2bbd58cef32f8d565.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--dicionario.js.sh11
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbab5310cc68..a5af96ca503a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dicionario.js-bin
pkgdesc = Simple dictionary in which you record your own words.
pkgver = 2.7.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ArthurLobopro/dicionario.js
arch = x86_64
license = MIT
@@ -12,6 +12,6 @@ pkgbase = dicionario.js-bin
source = dicionario.js-2.7.2.deb::https://github.com/ArthurLobopro/dicionario.js/releases/download/v2.7.2/dicionario.js_2.7.2_amd64.deb
source = dicionario.js.sh
sha256sums = 7908055fc91c0e6953563694f0167ae8e1962ae19cf6ccaeaabcc32147241acc
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = dicionario.js-bin
diff --git a/PKGBUILD b/PKGBUILD
index 17fce0e8617a..65753ace7502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dicionario.js-bin
pkgver=2.7.2
_electronversion=26
-pkgrel=2
+pkgrel=3
pkgdesc="Simple dictionary in which you record your own words."
arch=('x86_64')
url="https://github.com/ArthurLobopro/dicionario.js"
@@ -18,11 +18,11 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('7908055fc91c0e6953563694f0167ae8e1962ae19cf6ccaeaabcc32147241acc'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.zst"
}
diff --git a/dicionario.js.sh b/dicionario.js.sh
index c77c53567639..f9ced1432cfc 100644
--- a/dicionario.js.sh
+++ b/dicionario.js.sh
@@ -1,17 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file