summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-05-17 17:17:37 +0800
committerzxp198210052023-05-17 17:17:37 +0800
commite52cbf68143a8b2ee5168fd7ae44dab768f5c4d5 (patch)
treed5fbfae7599d3fbf63f5eca69d6c5b2ab8260157
downloadaur-e52cbf68143a8b2ee5168fd7ae44dab768f5c4d5.tar.gz
first release
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD24
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c330a55146e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = dicionario.js-bin
+ pkgdesc = Simple dictionary in which you record your own words.
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://github.com/ArthurLobopro/dicionario.js
+ arch = x86_64
+ license = MIT
+ makedepends = gendesk
+ depends = nss
+ depends = nodejs
+ depends = nspr
+ depends = gtk3
+ depends = glibc
+ depends = alsa-lib
+ depends = libxcomposite
+ depends = mesa
+ depends = libxrandr
+ depends = cairo
+ depends = libxcb
+ depends = at-spi2-core
+ depends = pango
+ depends = libxext
+ depends = gcc-libs
+ depends = libx11
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = glib2
+ depends = libxdamage
+ depends = libdrm
+ depends = dbus
+ depends = libcups
+ depends = expat
+ conflicts = dicionario.js
+ conflicts = dicionario.js-bin
+ noextract = dicionario.js-2.1.2.zip
+ options = !strip
+ source = dicionario.js-2.1.2.deb::https://github.com/ArthurLobopro/dicionario.js/releases/download/v2.1.2/dicionario.js_2.1.2_amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/ArthurLobopro/dicionario.js/main/LICENSE
+ sha256sums = 01b4fd9d89a656a7c97bbb18f598aea6a86724cadbfce17a33ab0e50a263c481
+ sha256sums = c898d2875697b8ed803b6f18c641a194614b29c26c638eb8135398bc80255e26
+
+pkgname = dicionario.js-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac61e8fe6e6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=dicionario.js-bin
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="Simple dictionary in which you record your own words."
+arch=('x86_64')
+url="https://github.com/ArthurLobopro/dicionario.js"
+license=('MIT')
+conflicts=("${pkgname%-bin}" "${pkgname%-ng-bin}")
+depends=('nss' 'nodejs' 'nspr' 'gtk3' 'glibc' 'alsa-lib' 'libxcomposite' 'mesa' 'libxrandr' 'cairo' 'libxcb' 'at-spi2-core' \
+ 'pango' 'libxext' 'gcc-libs' 'libx11' 'libxfixes' 'libxkbcommon' 'glib2' 'libxdamage' 'libdrm' 'dbus' 'libcups' 'expat')
+makedepends=('gendesk')
+options=(!strip)
+noextract=("${pkgname%-bin}-${pkgver}.zip")
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "LICENSE::https://raw.githubusercontent.com/ArthurLobopro/dicionario.js/main/LICENSE")
+sha256sums=('01b4fd9d89a656a7c97bbb18f598aea6a86724cadbfce17a33ab0e50a263c481'
+ 'c898d2875697b8ed803b6f18c641a194614b29c26c638eb8135398bc80255e26')
+
+package() {
+ bsdtar -xf "${srcdir}/data.tar.zst" -C "${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ chmod 0755 "${pkgdir}/usr/lib/${pkgname%-bin}/chrome-sandbox"
+} \ No newline at end of file