summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2018-08-28 10:49:03 -0300
committerRafael Fontenelle2018-08-28 10:50:07 -0300
commit8b50d169b160ac07da002ddd5fac61332e45394c (patch)
tree824bad52bee35519a53ff56bfa249781a953e541
parent9ed6667ebe71046354cbe302be6b1b4231caf434 (diff)
downloadaur-8b50d169b160ac07da002ddd5fac61332e45394c.tar.gz
Update to 2.6
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD40
-rw-r--r--stdio.patch12
4 files changed, 63 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aa0b0b70f6c..eaaad0a2057a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = dico
- pkgdesc = GNU Dico is a flexible modular implementation of DICT server (RFC 2229). In contrast to another implementations, it does not depend on particular database format. GNU Dico handles database accesses using loadable modules.
- pkgver = 2.2
+ pkgdesc = GNU Dictionary Server
+ pkgver = 2.6
pkgrel = 1
- url = ftp://download.gnu.org.ua/pub/release/dico
- arch = any
- license = GPLv3
- depends = libtool>=2.4.6
- depends = pcre>=8.38
- depends = guile>=2.0
- depends = python2>=2.7.11
- depends = gettext>=0.19.7
- source = ftp://download.gnu.org.ua/pub/release/dico/dico-2.2.tar.gz
- md5sums = 45145e4790ce64332b2d8e842ce5f957
+ url = http://puszcza.gnu.org.ua/software/dico
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = gsasl
+ depends = wordnet
+ depends = guile
+ depends = pam
+ source = ftp://download.gnu.org.ua/pub/release/dico/dico-2.6.tar.xz
+ source = ftp://download.gnu.org.ua/pub/release/dico/dico-2.6.tar.xz.sig
+ validpgpkeys = 325F650C4C2B6AD58807327A3602B07F55D0C732
+ sha1sums = a66771ec12d335351efc88614d7d79dddf4ae9c0
+ sha1sums = SKIP
pkgname = dico
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aace9926737
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
index 439f29cc6d85..13280ff09638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,38 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+
pkgname=dico
-pkgver=2.2
+pkgver=2.6
pkgrel=1
-pkgdesc="GNU Dico is a flexible modular implementation of DICT server (RFC 2229). In contrast to another implementations, it does not depend on particular database format. GNU Dico handles database accesses using loadable modules."
-arch=('any')
-url="ftp://download.gnu.org.ua/pub/release/$pkgname"
-license=(GPLv3)
-depends=('libtool>=2.4.6' 'pcre>=8.38' 'guile>=2.0' 'python2>=2.7.11' 'gettext>=0.19.7')
-source=("$url/$pkgname-$pkgver.tar.gz")
-md5sums=('45145e4790ce64332b2d8e842ce5f957')
+pkgdesc="GNU Dictionary Server"
+arch=('x86_64')
+url="http://puszcza.gnu.org.ua/software/$pkgname"
+license=(GPL3)
+depends=(python gsasl wordnet guile pam)
+source=("ftp://download.gnu.org.ua/pub/release/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+sha1sums=('a66771ec12d335351efc88614d7d79dddf4ae9c0'
+ 'SKIP')
+validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732')
+ # Sergey Poznyakoff <gray@gnu.org>
+ # To validate, see instructions at:
+ # https://puszcza.gnu.org.ua/software/dico/download.html
build() {
- cd "$srcdir/$pkgname-$pkgver/"
- patch -p1 < ../../stdio.patch
- ./configure DEFAULT_DICT_SERVER=dict.org
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/dico \
+ --sysconfdir=/etc \
+ --with-pcre \
+ --with-wordnet
make
}
+check() {
+ cd $pkgname-$pkgver
+ make -k check
+}
+
package() {
- cd "$srcdir/$pkgname-$pkgver/"
+ cd $pkgname-$pkgver
make PREFIX=/usr DESTDIR="$pkgdir" install
}
diff --git a/stdio.patch b/stdio.patch
deleted file mode 100644
index a35a4f72dcc3..000000000000
--- a/stdio.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur dico-2.2/gnu/stdio.in.h dico-2.2.1/gnu/stdio.in.h
---- dico-2.2/gnu/stdio.in.h 2012-01-09 12:39:33.000000000 +0100
-+++ dico-2.2.1/gnu/stdio.in.h 2016-06-22 05:02:58.420791647 +0200
-@@ -163,8 +163,6 @@
- /* It is very rare that the developer ever has full control of stdin,
- so any use of gets warrants an unconditional warning. Assume it is
- always declared, since it is required by C89. */
--#undef gets
--_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
-
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@