summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrespiranto2015-08-10 00:46:23 +0200
committerrespiranto2015-08-10 00:46:23 +0200
commit5a88f74a0ad2f4971ab9148579257ae85391a7fe (patch)
treeac63a68d5950bcefc7261f1e88ed8527c01eafd1
parent9e441f1e05e67ea28607fe95f937d211996f8935 (diff)
downloadaur-5a88f74a0ad2f4971ab9148579257ae85391a7fe.tar.gz
Improved the .install file and made dictd optional
- automated dictd configuration - notification if dictd is not installed - (re-)start dictd upon first install - restart dictd after each upgrade if it was running
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--dict-freedict-eng-spa.install72
3 files changed, 75 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aa5784fef74..3c336bd64506 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = dict-freedict-eng-spa
pkgdesc = English -> Spanish dictionary for dictd from Freedict.org
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.freedict.org/
install = dict-freedict-eng-spa.install
arch = any
license = GPL
- depends = dictd
+ makedepends = dictd
+ optdepends = dictd: dict client and server
source = http://sourceforge.net/projects/freedict/files/English%20-%20Spanish/0.2.1/freedict-eng-spa-0.2.1.tar.bz2
md5sums = 89abca9ccba27f3a34c7363a510b91a1
diff --git a/PKGBUILD b/PKGBUILD
index 4afdef0b6b02..7f4a44200666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: respiranto <respiranto@icloud.com>
pkgname=dict-freedict-eng-spa
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="English -> Spanish dictionary for dictd from Freedict.org"
arch=('any')
url="http://www.freedict.org/"
license=('GPL')
-depends=(dictd)
-install=dict-freedict-eng-spa.install
+optdepends=('dictd: dict client and server')
+makedepends=('dictd')
+install=$pkgname.install
source=("http://sourceforge.net/projects/freedict/files/English%20-%20Spanish/$pkgver/freedict-eng-spa-$pkgver.tar.bz2")
md5sums=('89abca9ccba27f3a34c7363a510b91a1')
diff --git a/dict-freedict-eng-spa.install b/dict-freedict-eng-spa.install
index cf923dd12079..dc010c66ac98 100644
--- a/dict-freedict-eng-spa.install
+++ b/dict-freedict-eng-spa.install
@@ -1,7 +1,71 @@
+pkgname=dict-freedict-eng-spa
+basename=eng-spa
+dictd_conf=/etc/dict/dictd.conf
+datadir=/usr/share/dictd
+conf="database $basename {
+ data $datadir/$basename.dict.dz
+ index $datadir/$basename.index
+}"
+
post_install()
{
- echo -e "\nYou have to configure dictd to use the new dictionary" \
- "database located in /usr/share/dictd/ manually" \
- "and restart the dictd service afterwards.\n\n" \
- "See also dictd(8).\n"
+ echo
+ if pacman -Qq dictd > /dev/null 2>&1
+ then
+ if grep -q "^database *$basename" "$dictd_conf"
+ then
+ echo "$pkgname already configured in $dictd_conf"
+ else
+ echo "Adding configuration for $pkgname to $dictd_conf"
+ echo -e "$conf" >> "$dictd_conf"
+ fi
+
+ if systemctl -q is-active dictd.service
+ then
+ echo "Restarting dictd service in order to" \
+ "use the new dictionary database"
+ systemctl restart dictd.service
+ else
+ echo "Starting dictd service in order to" \
+ "use the new dictionary database"
+ systemctl start dictd.service
+ fi
+ else
+ echo "dictd does not appear to be installed."
+ echo "In order to use this database you should either" \
+ "install dictd or alternatively" \
+ "another dict server and configure it on your own."
+ fi
+ echo
+}
+
+post_upgrade()
+{
+ if pacman -Qq dictd > /dev/null 2>&1 && \
+ systemctl -q is-active dictd.service
+ then
+ echo -e "\nRestarting dictd service in order to" \
+ "use the updated dictionary database"
+ systemctl restart dictd.service
+ fi
+}
+
+post_remove()
+{
+ if pacman -Qq dictd > /dev/null 2>&1
+ then
+ current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
+ if test -n "$current_conf"
+ then
+ echo
+ if test "$current_conf" = "$conf"
+ then
+ echo "Removing configuration for $pkgname from $dictd_conf"
+ sed -i "/database $basename {/,/}/d" "$dictd_conf"
+ else
+ echo "User created / modified configuration" \
+ "for $pkgname in $dictd_conf is left untouched."
+ fi
+ fi
+ fi
}