summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrespiranto2015-08-10 00:50:05 +0200
committerrespiranto2015-08-10 00:50:05 +0200
commit16921a6a47caf2e3a4bc65d91264af6d466afc03 (patch)
tree930ae1bb9778a3fc3efcb54be69fb43897f7212a
parent51970d7a8264f126856d03ade624b229ebda5414 (diff)
downloadaur-16921a6a47caf2e3a4bc65d91264af6d466afc03.tar.gz
Improved the .install file and made dictd optional
- automated dictd configuration - notification if dictd is not installed - (re-)start dictd upon first install - restart dictd after each upgrade if it was running
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--dict-freedict-fra-deu.install72
3 files changed, 75 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a133462c92c6..43263e045401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = dict-freedict-fra-deu
pkgdesc = French -> German dictionary for dictd from Freedict.org
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.freedict.org/
install = dict-freedict-fra-deu.install
arch = any
license = GPL
- depends = dictd
+ makedepends = dictd
+ optdepends = dictd: dict client and server
source = http://sourceforge.net/projects/freedict/files/French%20-%20German/0.1.1/freedict-fra-deu-0.1.1.tar.bz2
md5sums = b90134466560207553649c319bd92278
diff --git a/PKGBUILD b/PKGBUILD
index 05de1a2339ef..f3b3d73cdad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: respiranto <respiranto@icloud.com>
pkgname=dict-freedict-fra-deu
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="French -> German dictionary for dictd from Freedict.org"
arch=('any')
url="http://www.freedict.org/"
license=('GPL')
-depends=(dictd)
-install=dict-freedict-fra-deu.install
+optdepends=('dictd: dict client and server')
+makedepends=('dictd')
+install=$pkgname.install
source=("http://sourceforge.net/projects/freedict/files/French%20-%20German/$pkgver/freedict-fra-deu-$pkgver.tar.bz2")
md5sums=('b90134466560207553649c319bd92278')
diff --git a/dict-freedict-fra-deu.install b/dict-freedict-fra-deu.install
index cf923dd12079..111614d60def 100644
--- a/dict-freedict-fra-deu.install
+++ b/dict-freedict-fra-deu.install
@@ -1,7 +1,71 @@
+pkgname=dict-freedict-fra-deu
+basename=fra-deu
+dictd_conf=/etc/dict/dictd.conf
+datadir=/usr/share/dictd
+conf="database $basename {
+ data $datadir/$basename.dict.dz
+ index $datadir/$basename.index
+}"
+
post_install()
{
- echo -e "\nYou have to configure dictd to use the new dictionary" \
- "database located in /usr/share/dictd/ manually" \
- "and restart the dictd service afterwards.\n\n" \
- "See also dictd(8).\n"
+ echo
+ if pacman -Qq dictd > /dev/null 2>&1
+ then
+ if grep -q "^database *$basename" "$dictd_conf"
+ then
+ echo "$pkgname already configured in $dictd_conf"
+ else
+ echo "Adding configuration for $pkgname to $dictd_conf"
+ echo -e "$conf" >> "$dictd_conf"
+ fi
+
+ if systemctl -q is-active dictd.service
+ then
+ echo "Restarting dictd service in order to" \
+ "use the new dictionary database"
+ systemctl restart dictd.service
+ else
+ echo "Starting dictd service in order to" \
+ "use the new dictionary database"
+ systemctl start dictd.service
+ fi
+ else
+ echo "dictd does not appear to be installed."
+ echo "In order to use this database you should either" \
+ "install dictd or alternatively" \
+ "another dict server and configure it on your own."
+ fi
+ echo
+}
+
+post_upgrade()
+{
+ if pacman -Qq dictd > /dev/null 2>&1 && \
+ systemctl -q is-active dictd.service
+ then
+ echo -e "\nRestarting dictd service in order to" \
+ "use the updated dictionary database"
+ systemctl restart dictd.service
+ fi
+}
+
+post_remove()
+{
+ if pacman -Qq dictd > /dev/null 2>&1
+ then
+ current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
+ if test -n "$current_conf"
+ then
+ echo
+ if test "$current_conf" = "$conf"
+ then
+ echo "Removing configuration for $pkgname from $dictd_conf"
+ sed -i "/database $basename {/,/}/d" "$dictd_conf"
+ else
+ echo "User created / modified configuration" \
+ "for $pkgname in $dictd_conf is left untouched."
+ fi
+ fi
+ fi
}