summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2018-03-31 22:22:39 +0200
committerEinhard Leichtfuß2018-03-31 22:22:39 +0200
commit4f93f2a5ab1d6078d54863f0454d5073641d2ba0 (patch)
tree173a8855875a81cd85c73653664d08c74da7e3a5
parent1184cafcaaf6adbc5efdac3d2fd2f279a21c757c (diff)
downloadaur-4f93f2a5ab1d6078d54863f0454d5073641d2ba0.tar.gz
Replace cp by install
and thereby remove the need for explicitly creating the directory to copy the docs in, which might have been pointless in the case of no doc existing. Also, replace the short-circuiting using `&&' by an if-statement in order to prevent package() from failing. The changes do not affect the resulting package.
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caf511d26bfd..5b8504d72332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,14 +22,15 @@ build()
package()
{
- mkdir -p "${pkgdir}/usr/share/dictd"
- cp ${_lang}/build/dictd/${_lang}.{dict.dz,index} \
- "${pkgdir}/usr/share/dictd/"
+ install -m 755 -d "${pkgdir}/usr/share/dictd"
+ install -m 644 -t "${pkgdir}/usr/share/dictd/" \
+ ${_lang}/build/dictd/${_lang}.{dict.dz,index}
- mkdir -p "${pkgdir}/usr/share/doc/freedict/${_lang}"
for file in ${_lang}/{AUTHORS,README,NEWS,ChangeLog}
do
- test -f ${file} && \
- cp ${file} "${pkgdir}/usr/share/doc/freedict/${_lang}/"
+ if test -f ${file}
+ then
+ install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" ${file}
+ fi
done
}