summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2018-04-01 01:45:50 +0200
committerEinhard Leichtfuß2018-04-01 01:45:50 +0200
commit36edaca4c06f610e79fa1f0cdc1c909019ab29cb (patch)
tree63993bf8f577d09a528e7faa5e5b213d625fd141
parent8e5e7d630a976cc69478e32742952a268c19a201 (diff)
downloadaur-36edaca4c06f610e79fa1f0cdc1c909019ab29cb.tar.gz
Replace `cp' by `install' and specify make target
Replacing `cp' by `install' removes the need for explicitly creating the directory to copy the docs in, which might have been pointless in the case of no such file to be copied existing. Explicitly specifying the make target appears to be required now; also the location of the built dictionary files has changed. Finally, replace the short-circuiting using `&&' by an if-statement in order to prevent package() from failing.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b737121dfdc..91a5b40236b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dict-freedict-fra-eng-svn
pkgdesc = French -> English dictionary for dictd et al. from Freedict.org
- pkgver = r1629
- pkgrel = 1
+ pkgver = r1775
+ pkgrel = 2
url = http://www.freedict.org/
install = dict-freedict-fra-eng-svn.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 8d09206bb5fa..1382ad3c803f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Einhard Leichtfuß <archer@respiranto.de>
+# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
_lang=fra-eng
_pkgname=dict-freedict-${_lang}
pkgname=${_pkgname}-svn
-pkgver=r1629
-pkgrel=1
+pkgver=r1775
+pkgrel=2
pkgdesc="French -> English dictionary for dictd et al. from Freedict.org"
arch=('any')
url="http://www.freedict.org/"
@@ -18,26 +18,28 @@ md5sums=('SKIP')
pkgver()
{
- cd ${_lang}
+ cd $_lang
local _ver="$(svnversion)"
printf "r%s" "${_ver//[[:alpha:]]}"
}
build()
{
- cd ${_lang}
- make FREEDICT_TOOLS=/usr/lib/freedict-tools
+ cd $_lang
+ make FREEDICT_TOOLS=/usr/lib/freedict-tools build-dictd
}
package()
{
- mkdir -p "${pkgdir}/usr/share/dictd"
- cp ${_lang}/${_lang}.{dict.dz,index} "$pkgdir/usr/share/dictd/"
+ install -m 755 -d "${pkgdir}/usr/share/dictd"
+ install -m 644 -t "${pkgdir}/usr/share/dictd/" \
+ ${_lang}/build/dictd/${_lang}.{dict.dz,index}
- mkdir -p "${pkgdir}/usr/share/doc/freedict/${_lang}"
for file in ${_lang}/{AUTHORS,README,NEWS,ChangeLog}
do
- test -f ${file} && \
- cp ${file} "${pkgdir}/usr/share/doc/freedict/${_lang}/"
+ if test -f ${file}
+ then
+ install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" ${file}
+ fi
done
}