summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2017-08-01 01:39:27 +0200
committerEinhard Leichtfuß2017-08-01 01:41:39 +0200
commit85807a053b1abda4c177288e59435868286c326a (patch)
tree28694373c92314e768ec401584ac4200cb322566
parentcecfcb23dcf27a60b500292c3c1a66d99762f561 (diff)
downloadaur-85807a053b1abda4c177288e59435868286c326a.tar.gz
Update to version 0.51
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
-rw-r--r--fixes.sed20
3 files changed, 74 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf0a86d6694..4e8d49a567cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,26 @@
pkgbase = dict-gcide
pkgdesc = GNU version of the Collaborative International Dictionary of English for dictd et al.
- pkgver = 0.48.1
- pkgrel = 7
- url = http://www.dict.org/
+ pkgver = 0.51
+ pkgrel = 1
+ url = http://gcide.gnu.org.ua/
install = dict-gcide.install
arch = any
license = GPL
+ license = GPL3
makedepends = dictd
+ makedepends = sed
optdepends = dictd: dict client and server
provides = dictd-gcide
conflicts = dictd-gcide
- source = ftp://ftp.debian.org/debian/pool/main/d/dict-gcide/dict-gcide_0.48.1.tar.gz
- sha512sums = 87a5aae9952316e03e029424de06e36bec46ce1a24dd300eecaf73577f6785c18cbade1d4227ac38b505a8b64ad36bac64893f4a7dc25b87760df0a4e384fbc4
+ source = fixes.sed
+ source = http://ftp.debian.org/debian/pool/main/d/dict-gcide/dict-gcide_0.48.4.tar.xz
+ source = ftp://ftp.gnu.org/gnu/gcide/gcide-0.51.tar.xz
+ source = ftp://ftp.gnu.org/gnu/gcide/gcide-0.51.tar.xz.sig
+ validpgpkeys = 325F650C4C2B6AD58807327A3602B07F55D0C732
+ sha512sums = 3adc1c75e9f96883966236131518b4b8f4c6c588759112417ec46c35d421da87ddd1bac156fa0bf55c64f939cbe1efd235d0854b4dfe8cfa1278917d6fef07f5
+ sha512sums = 82939f8c9e2bb30368b673784abaf85724a04fb9ebab382b6908034e0978d4d47039b7667573b88fe074bb29ea232b9e11129ac30ba6e88d5b9271df3b2ad302
+ sha512sums = a388a43d255c28a933d301140f233ae602249dc1fa223dd91ea8c4b2fc0736ff88ed60357b08050217b5513638c7015e4c99dfd084cfad61eec503822558711a
+ sha512sums = SKIP
pkgname = dict-gcide
diff --git a/PKGBUILD b/PKGBUILD
index 9890ffe80846..52361b615cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,61 @@
# Maintainer: Einhard Leichtfuß <archer@respiranto.de>
# Contributor: Tai Chi Minh Ralph Eastwood <tcmreastwood@gmail.com>
pkgname=dict-gcide
-pkgver=0.48.1
-pkgrel=7
+_debver=0.48.4
+pkgver=0.51
+pkgrel=1
pkgdesc="GNU version of the Collaborative International Dictionary of English for dictd et al."
arch=('any')
-url="http://www.dict.org/"
-license=('GPL')
+url="http://gcide.gnu.org.ua/"
+license=('GPL' 'GPL3')
optdepends=('dictd: dict client and server')
-makedepends=('dictd')
+makedepends=('dictd' 'sed')
provides=('dictd-gcide')
conflicts=('dictd-gcide')
-install=$pkgname.install
-source=("ftp://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.gz")
-sha512sums=('87a5aae9952316e03e029424de06e36bec46ce1a24dd300eecaf73577f6785c18cbade1d4227ac38b505a8b64ad36bac64893f4a7dc25b87760df0a4e384fbc4')
+install=${pkgname}.install
+source=('fixes.sed'
+ "http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${_debver}.tar.xz"
+ "ftp://ftp.gnu.org/gnu/gcide/gcide-${pkgver}.tar.xz"{,.sig})
+sha512sums=('3adc1c75e9f96883966236131518b4b8f4c6c588759112417ec46c35d421da87ddd1bac156fa0bf55c64f939cbe1efd235d0854b4dfe8cfa1278917d6fef07f5'
+ '82939f8c9e2bb30368b673784abaf85724a04fb9ebab382b6908034e0978d4d47039b7667573b88fe074bb29ea232b9e11129ac30ba6e88d5b9271df3b2ad302'
+ 'a388a43d255c28a933d301140f233ae602249dc1fa223dd91ea8c4b2fc0736ff88ed60357b08050217b5513638c7015e4c99dfd084cfad61eec503822558711a'
+ 'SKIP')
+validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732')
+
+prepare() {
+ ln -s "${srcdir}/fixes.sed" "${pkgname}-${_debver}/"
+ sed -i 's`\(\./webfilter\) | \(\./webfmt -c\)`\1 | sed -Ef fixes.sed | \2`' "${pkgname}-${_debver}/Makefile.in"
+
+ rm -rf "${pkgname}-${_debver}/cide"
+ ln -s "${srcdir}/gcide-0.51" "${pkgname}-${_debver}/cide"
+ cd "${pkgname}-${_debver}/cide"
+ for file in CIDE.?
+ do
+ mv "$file" "${file,,}"
+ done
+ mv tagset.{txt,web}
+ mv webfont.{txt,asc}
+ mv README{,.dic}
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${_debver}"
export CPPFLAGS="-D_FORTIFY_SOURCE=0"
./configure --with-local-libmaa --prefix=/usr
make -j1
mkdir "../final_data"
make dictdir="../final_data" install
# Fix wrong order.
- LANG=C sort --dictionary-order --ignore-case -o "../final_data"/gcide.index{,}
+ LANG=C sort --dictionary-order --ignore-case \
+ -o ../final_data/gcide.index{,}
}
package()
{
- mkdir -p "$pkgdir/usr/share/dictd"
- cp "final_data"/* "$pkgdir/usr/share/dictd/"
- mkdir -p "$pkgdir/usr/share/doc/dict-gcide"
- cp "$pkgname-$pkgver/cide/README.dic" "$pkgdir/usr/share/doc/dict-gcide/"
+ install -m 0755 -d "${pkgdir}/usr/share/dictd"
+ install -m 0644 -t "${pkgdir}/usr/share/dictd/" \
+ final_data/gcide.{dict.dz,index}
+ install -m 0755 -d "${pkgdir}/usr/share/doc/dict-gcide"
+ install -m 0644 -t "${pkgdir}/usr/share/doc/dict-gcide/" \
+ "${pkgname}-${_debver}/cide/"{README.dic,INFO}
}
diff --git a/fixes.sed b/fixes.sed
new file mode 100644
index 000000000000..b135ecaaffb3
--- /dev/null
+++ b/fixes.sed
@@ -0,0 +1,20 @@
+s`(<altname>|<contr>)<cref>([^<]*)</cref>`\1\2`g
+s`(<stype>|<prod>)<ecol>([^<]*)</ecol>`\1\2`g
+
+s`<col>([^<]*),? <cd>([^<]*)</col>`<col>\1</col>, <cd>\2`g
+
+s`(<qau>[^<]*)(<book>|<publ>)([^<]*)(</book>|</publ>)`\1\3`g
+
+s`<qau>([^<]*)(<break>)`<qau>\1</qau>\2`
+s`^([^<]*)</qau>`\1`
+s`<qau>([^<]*) (\([^)]{20}[^<]*)</qau>`<qau>\1</qau> \2`
+
+s`<au>([^<]*)<break>`<au>\1</au><break>`
+s`^([^<]*)</au>`\1`
+
+s`,? <[^>]*></[^>]*> ?``g
+s`</>``g
+
+s`(<qau>Andrew Hood), in`\1`
+s`\(Thirteenth Greatest of Centuries, 1913.`&)`
+/<a href="\\cide\\more\\lilac-breasted-roller.jpg">/,/zambezi.co.uk/d