summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEhsan G2021-09-12 21:33:56 +0430
committerEhsan G2021-09-12 21:33:56 +0430
commitcddf7c450a9788bcacdc6abcbd6222721397970f (patch)
tree34a91ce5110d32a4c6db37484b155352ccb5c43e
downloadaur-cddf7c450a9788bcacdc6abcbd6222721397970f.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rwxr-xr-xdictd.finish2
-rwxr-xr-xdictd.run5
4 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30bd3cc53fde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dictd-runit
+ pkgdesc = runit service scripts for dictd
+ pkgver = r1
+ pkgrel = 1
+ url = https://aur.archlinux.org/packages/dictd-runit
+ arch = any
+ license = GPL
+ depends = runit
+ depends = dictd
+ source = dictd.run
+ source = dictd.finish
+ sha256sums = 03e14ddf8a5bbe63625d96a8942ad166b467ae7b78672035964e7dc2bdbd9965
+ sha256sums = 22a2152e470acbeda7059141314d270d8e727719b8cf7c43e7265480add2187d
+
+pkgname = dictd-runit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e2bcabcac5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Ehsan Ghorbannezad <ehsangn@protonmail.ch>
+pkgname=dictd-runit
+pkgver=r1
+pkgrel=1
+pkgdesc='runit service scripts for dictd'
+url="https://aur.archlinux.org/packages/$pkgname"
+arch=(any)
+license=(GPL)
+depends=(runit dictd)
+source=(dictd.run dictd.finish)
+sha256sums=('03e14ddf8a5bbe63625d96a8942ad166b467ae7b78672035964e7dc2bdbd9965'
+ '22a2152e470acbeda7059141314d270d8e727719b8cf7c43e7265480add2187d')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 ${source[@]} -t "$pkgdir/etc/runit/sv/dictd/run"
+}
diff --git a/dictd.finish b/dictd.finish
new file mode 100755
index 000000000000..8c9aa23d68a5
--- /dev/null
+++ b/dictd.finish
@@ -0,0 +1,2 @@
+#!/bin/sh
+killall -q dictd
diff --git a/dictd.run b/dictd.run
new file mode 100755
index 000000000000..5f904e3bbe9e
--- /dev/null
+++ b/dictd.run
@@ -0,0 +1,5 @@
+#!/bin/sh
+killall -q dictd
+[ -r /etc/conf.d/dictd ] && . /etc/conf.d/dictd
+/usr/bin/dictd $DICTD_ARGS -- $DICTD_EARGS &&
+ exec pwait -nx dictd