summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:36:08 +0200
committerStefan Husmann2015-06-08 20:36:08 +0200
commita340c4a3e89c96cdd15603f7a7d6ef8d31d04ce5 (patch)
tree61ab45dc634460c73027b9f57ca028e9f28b3f92
downloadaur-a340c4a3e89c96cdd15603f7a7d6ef8d31d04ce5.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--dictionary.install8
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42bc4da7c3c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dictionary
+ pkgdesc = Emacs interface to dictd dictionary servers.
+ pkgver = 1.10
+ pkgrel = 1
+ url = http://www.myrkr.in-berlin.de/dictionary/
+ install = dictionary.install
+ arch = any
+ license = GPL
+ depends = emacs
+ source = http://www.myrkr.in-berlin.de/dictionary/dictionary-1.10.tar.gz
+ md5sums = fdd7d53d1010261276dbb23ea15f017a
+
+pkgname = dictionary
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a7f9d6c68b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: James Cozine <jmcozine@gmail.com>
+
+pkgname=dictionary
+pkgver=1.10
+pkgrel=1
+pkgdesc="Emacs interface to dictd dictionary servers."
+arch=('any')
+url="http://www.myrkr.in-berlin.de/dictionary/"
+license=('GPL')
+depends=('emacs')
+install="$pkgname.install"
+source=("http://www.myrkr.in-berlin.de/dictionary/$pkgname-$pkgver.tar.gz")
+md5sums=('fdd7d53d1010261276dbb23ea15f017a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/dictionary"
+ install -m 644 *.el{,c} "${pkgdir}/usr/share/emacs/site-lisp/dictionary"
+}
diff --git a/dictionary.install b/dictionary.install
new file mode 100644
index 000000000000..49f22f0e4f46
--- /dev/null
+++ b/dictionary.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ">>" Add the following to your .emacs:
+ echo ">> (add-to-list 'load-path \"/usr/share/emacs/site-lisp/dictionary/\")"
+ echo ">> (load \"dictionary-init\")"
+ echo ">>" Useful keybindings:
+ echo ">> (global-set-key \"\\C-cs\" 'dictionary-search)"
+ echo ">> (global-set-key \"\\C-cm\" 'dictionary-match-words)"
+}