aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjiale2020-08-10 11:14:07 +0800
committerjiale2020-08-10 11:14:07 +0800
commit61b763977b145d0e9221f19355a20a56f98d390c (patch)
treef0ecd3d2dcb929fe0f468641bd469f354bc7c493
downloadaur-61b763977b145d0e9221f19355a20a56f98d390c.tar.gz
修改发布包
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD48
-rw-r--r--README.md5
-rw-r--r--dida.desktop21
-rw-r--r--dida.sh7
7 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e93edb26241c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 5.2.2
+# Mon Aug 10 02:58:53 UTC 2020
+pkgbase = dida-git
+ pkgdesc = 使用electron包装的滴答客户端
+ pkgver = v1.0.3.r0.g40a853e
+ pkgrel = 1
+ url = https://github.com/jialeens/dida
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = sed
+ makedepends = gcc
+ depends = electron
+ provides = dida
+ conflicts = dida
+ source = dida-git::git+https://github.com/jialeens/dida.git
+ source = dida.desktop
+ source = dida.sh
+ sha256sums = SKIP
+ sha256sums = 2900c26c1209f94033b94c38ad754aa2941f2acbf681f8c30a04f83b128d3f13
+ sha256sums = 24a3b6e4300741f8184395a9d628076205f249201658a318c1eebaec6f613884
+
+pkgname = dida-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6ddda625caa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/package/pkg
+/package/src
+/package/dida \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5460ac16e265
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 jialeens
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5957783ab5a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: jialeens <jialeadmin@163.com>
+
+pkgname=dida-git
+pkgver=v1.0.3.r0.g40a853e
+pkgrel=1
+pkgdesc="使用electron包装的滴答客户端"
+arch=('any')
+url="https://github.com/jialeens/dida"
+license=("MIT")
+groups=()
+depends=('electron')
+makedepends=('git' 'npm' 'sed' 'gcc')
+checkdepends=()
+optdepends=()
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git+$url.git"
+ "dida.desktop"
+ "dida.sh")
+noextract=()
+sha256sums=("SKIP"
+ "2900c26c1209f94033b94c38ad754aa2941f2acbf681f8c30a04f83b128d3f13"
+ "24a3b6e4300741f8184395a9d628076205f249201658a318c1eebaec6f613884")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ npm install
+ npm run package
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/$pkgname"
+ cp -r --no-preserve='ownership' -- $pkgname/dist/dida-linux-x64/* "$pkgdir/usr/lib/$pkgname"
+ install -Dm644 "$srcdir/$pkgname/dida.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/dida.png"
+ install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "dida.sh" "$pkgdir/usr/bin/dida"
+ install -Dm644 "dida.desktop" -t "$pkgdir/usr/share/applications"
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5abe509590ee
--- /dev/null
+++ b/README.md
@@ -0,0 +1,5 @@
+# dida-package
+滴答清单electron的aur构建程序
+```shell
+makepkg
+```
diff --git a/dida.desktop b/dida.desktop
new file mode 100644
index 000000000000..ad5f99df2c18
--- /dev/null
+++ b/dida.desktop
@@ -0,0 +1,21 @@
+[Desktop Entry]
+Categories=Development;
+Comment=dida
+Comment[zh_CN]=滴答清单
+Exec="/usr/bin/dida"
+GenericName=dida
+GenericName[zh_CN]=滴答清单
+Icon=dida
+MimeType=
+Name=滴答清单
+Name[zh_CN]=滴答清单
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+Version=1.9.1
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username= \ No newline at end of file
diff --git a/dida.sh b/dida.sh
new file mode 100644
index 000000000000..4f9842870969
--- /dev/null
+++ b/dida.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+PACKAGE_NAME="dida"
+EW_DIR="/usr/lib/$PACKAGE_NAME"
+
+cd "$EW_DIR" || exit 1
+exec ./dida