summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-29 04:38:19 +0200
committerChristopher Arndt2022-09-29 04:38:19 +0200
commit4ae8de3467769b5fe3748db2b58e990695c88cc8 (patch)
treee80536958bc0b2e1e8a9be252f46a1b35dbdbb20
downloadaur-4ae8de3467769b5fe3748db2b58e990695c88cc8.tar.gz
Add new package die-plugins
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
-rw-r--r--die-plugins-maintainer-mod-brand.patch496
4 files changed, 563 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a14536838a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = die-plugins
+ pkgdesc = DISTRHO Imported Effect Plugins, Ardour's plugins without Ardour
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/DISTRHO/DIE-Plugins
+ arch = x86_64
+ groups = lv2-plugins
+ groups = pro-audio
+ license = GPL2
+ makedepends = git
+ makedepends = glib2
+ makedepends = libsndfile
+ makedepends = lv2
+ depends = glibc
+ depends = gcc-libs
+ optdepends = lv2-host: for loading LV2 plugins
+ source = DIE-Plugins-1.1.tar.gz::https://github.com/DISTRHO/DIE-Plugins/archive/refs/tags/v1.1.tar.gz
+ source = die-plugins-maintainer-mod-brand.patch::https://github.com/DISTRHO/DIE-Plugins/pull/1.diff
+ sha256sums = bef945fd7534a4bdaacd6bc57548ac3a9da97446c2b2e5a56b27ebfa2092a49a
+ sha256sums = ee961e520e0bf0d98899fcc284cf7d4dbad6b59d0d98ed1ab1d4411889ead12a
+
+pkgname = die-plugins
+ depends = glibc
+ depends = gcc-libs
+ depends = libglib-2.0.so
+ depends = libsndfile.so
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f490bd2b8509
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+DIE-Plugins-*.tar.gz
+pkg/
+src/
+die-plugins-*.pkg.tar.*
+die-plugins-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c7f062aa55d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name=DIE-Plugins
+pkgname=${_name,,}
+pkgdesc="DISTRHO Imported Effect Plugins, Ardour's plugins without Ardour"
+pkgver=1.1
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/DISTRHO/$_name"
+license=(GPL2)
+groups=(lv2-plugins pro-audio)
+depends=(glibc gcc-libs)
+makedepends=(git glib2 libsndfile lv2)
+optdepends=('lv2-host: for loading LV2 plugins')
+source=("$_name-$pkgver.tar.gz::https://github.com/DISTRHO/$_name/archive/refs/tags/v$pkgver.tar.gz"
+ 'die-plugins-maintainer-mod-brand.patch::https://github.com/DISTRHO/DIE-Plugins/pull/1.diff')
+sha256sums=('bef945fd7534a4bdaacd6bc57548ac3a9da97446c2b2e5a56b27ebfa2092a49a'
+ 'ee961e520e0bf0d98899fcc284cf7d4dbad6b59d0d98ed1ab1d4411889ead12a')
+
+
+prepare() {
+ cd $_name-$pkgver
+ patch -p1 -N -r - -i "$srcdir"/die-plugins-maintainer-mod-brand.patch
+}
+
+build() {
+ cd $_name-$pkgver
+ make
+}
+
+package() {
+ depends+=(libglib-2.0.so libsndfile.so)
+ cd $_name-$pkgver
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ chmod +x "$pkgdir"/usr/lib/lv2/*.lv2/*.so
+}
diff --git a/die-plugins-maintainer-mod-brand.patch b/die-plugins-maintainer-mod-brand.patch
new file mode 100644
index 000000000000..3399e4dda3b5
--- /dev/null
+++ b/die-plugins-maintainer-mod-brand.patch
@@ -0,0 +1,496 @@
+diff --git a/patches/ttl-maintaner.patch b/patches/ttl-maintaner.patch
+new file mode 100644
+index 0000000..071332f
+--- /dev/null
++++ b/patches/ttl-maintaner.patch
+@@ -0,0 +1,134 @@
++diff --git a/plugins/a-comp.lv2/a-comp#stereo.ttl.in b/plugins/a-comp.lv2/a-comp#stereo.ttl.in
++index dd84c75..dc7f2d3 100644
++--- a/plugins/a-comp.lv2/a-comp#stereo.ttl.in
+++++ b/plugins/a-comp.lv2/a-comp#stereo.ttl.in
++@@ -185,5 +185,10 @@ A powerful stereo compressor.
++ doap:license "GPL v2+" ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 2 .
++diff --git a/plugins/a-comp.lv2/a-comp.ttl.in b/plugins/a-comp.lv2/a-comp.ttl.in
++index 23adaa6..a76910c 100644
++--- a/plugins/a-comp.lv2/a-comp.ttl.in
+++++ b/plugins/a-comp.lv2/a-comp.ttl.in
++@@ -169,8 +169,13 @@ A powerful mono compressor.
++ """ ;
++
++ doap:name "DIE Compressor" ;
++- doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 2 .
++diff --git a/plugins/a-delay.lv2/a-delay.ttl.in b/plugins/a-delay.lv2/a-delay.ttl.in
++index c5c4ccd..2681da5 100644
++--- a/plugins/a-delay.lv2/a-delay.ttl.in
+++++ b/plugins/a-delay.lv2/a-delay.ttl.in
++@@ -183,5 +183,10 @@ A simple delay plugin
++ doap:license "GPL v2+" ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 4 .
++diff --git a/plugins/a-eq.lv2/a-eq.ttl.in b/plugins/a-eq.lv2/a-eq.ttl.in
++index 44efb56..118d9fc 100644
++--- a/plugins/a-eq.lv2/a-eq.ttl.in
+++++ b/plugins/a-eq.lv2/a-eq.ttl.in
++@@ -311,5 +311,10 @@ A basic 4 band EQ.
++ doap:license "GPL v2+" ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 2 .
++diff --git a/plugins/a-exp.lv2/a-exp#stereo.ttl.in b/plugins/a-exp.lv2/a-exp#stereo.ttl.in
++index 72bce7f..120689e 100644
++--- a/plugins/a-exp.lv2/a-exp#stereo.ttl.in
+++++ b/plugins/a-exp.lv2/a-exp#stereo.ttl.in
++@@ -175,8 +175,13 @@ A powerful stereo expander
++ """ ;
++
++ doap:name "DIE Expander (stereo)" ;
++- doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 2 .
++diff --git a/plugins/a-exp.lv2/a-exp.ttl.in b/plugins/a-exp.lv2/a-exp.ttl.in
++index b98c5fb..38b3237 100644
++--- a/plugins/a-exp.lv2/a-exp.ttl.in
+++++ b/plugins/a-exp.lv2/a-exp.ttl.in
++@@ -170,8 +170,13 @@ A powerful mono expander
++ """ ;
++
++ doap:name "DIE Expander" ;
++- doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 2 .
++diff --git a/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in b/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
++index b96e947..fd8cb18 100644
++--- a/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
+++++ b/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
++@@ -33,6 +33,11 @@
++ doap:developer <http://ardour.org/credits.html> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 2 ;
++ lv2:minorVersion 2 ;
++
++diff --git a/plugins/a-reverb.lv2/a-reverb.ttl.in b/plugins/a-reverb.lv2/a-reverb.ttl.in
++index 66e1a91..29e3125 100644
++--- a/plugins/a-reverb.lv2/a-reverb.ttl.in
+++++ b/plugins/a-reverb.lv2/a-reverb.ttl.in
++@@ -20,6 +20,11 @@
++ doap:developer <http://ardour.org/credits.html> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++
+++ doap:maintainer [
+++ foaf:name "DISTRHO" ;
+++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+++ ] ;
+++
++ lv2:microVersion 4 ;
++ lv2:minorVersion 2 ;
++ lv2:optionalFeature lv2:hardRTCapable ;
+diff --git a/patches/ttl-mod-brand.patch b/patches/ttl-mod-brand.patch
+new file mode 100644
+index 0000000..5e24c11
+--- /dev/null
++++ b/patches/ttl-mod-brand.patch
+@@ -0,0 +1,152 @@
++diff --git a/plugins/a-comp.lv2/a-comp#stereo.ttl.in b/plugins/a-comp.lv2/a-comp#stereo.ttl.in
++index dc7f2d3..13f17c2 100644
++--- a/plugins/a-comp.lv2/a-comp#stereo.ttl.in
+++++ b/plugins/a-comp.lv2/a-comp#stereo.ttl.in
++@@ -1,6 +1,7 @@
++ @prefix doap: <http://usefulinc.com/ns/doap#> .
++ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
++ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
+++@prefix mod: <http://moddevices.com/ns/mod#> .
++ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
++ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
++ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
++@@ -185,6 +186,8 @@ A powerful stereo compressor.
++ doap:license "GPL v2+" ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-comp.lv2/a-comp.ttl.in b/plugins/a-comp.lv2/a-comp.ttl.in
++index a76910c..d36eaee 100644
++--- a/plugins/a-comp.lv2/a-comp.ttl.in
+++++ b/plugins/a-comp.lv2/a-comp.ttl.in
++@@ -2,6 +2,7 @@
++ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
++ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
++ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
+++@prefix mod: <http://moddevices.com/ns/mod#> .
++ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
++ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
++ @prefix unit: <http://lv2plug.in/ns/extensions/units#> .
++@@ -172,6 +173,8 @@ A powerful mono compressor.
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-delay.lv2/a-delay.ttl.in b/plugins/a-delay.lv2/a-delay.ttl.in
++index 2681da5..1fc8ef2 100644
++--- a/plugins/a-delay.lv2/a-delay.ttl.in
+++++ b/plugins/a-delay.lv2/a-delay.ttl.in
++@@ -3,6 +3,7 @@
++ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
++ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
++ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
+++@prefix mod: <http://moddevices.com/ns/mod#> .
++ @prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
++ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
++ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
++@@ -183,6 +184,8 @@ A simple delay plugin
++ doap:license "GPL v2+" ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-eq.lv2/a-eq.ttl.in b/plugins/a-eq.lv2/a-eq.ttl.in
++index 118d9fc..a55d151 100644
++--- a/plugins/a-eq.lv2/a-eq.ttl.in
+++++ b/plugins/a-eq.lv2/a-eq.ttl.in
++@@ -2,6 +2,7 @@
++ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
++ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
++ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
+++@prefix mod: <http://moddevices.com/ns/mod#> .
++ @prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
++ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
++ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
++@@ -311,6 +312,8 @@ A basic 4 band EQ.
++ doap:license "GPL v2+" ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-exp.lv2/a-exp#stereo.ttl.in b/plugins/a-exp.lv2/a-exp#stereo.ttl.in
++index 120689e..7d4abc4 100644
++--- a/plugins/a-exp.lv2/a-exp#stereo.ttl.in
+++++ b/plugins/a-exp.lv2/a-exp#stereo.ttl.in
++@@ -2,6 +2,7 @@
++ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
++ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
++ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
+++@prefix mod: <http://moddevices.com/ns/mod#> .
++ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
++ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
++ @prefix unit: <http://lv2plug.in/ns/extensions/units#> .
++@@ -178,6 +179,8 @@ A powerful stereo expander
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-exp.lv2/a-exp.ttl.in b/plugins/a-exp.lv2/a-exp.ttl.in
++index 38b3237..c455376 100644
++--- a/plugins/a-exp.lv2/a-exp.ttl.in
+++++ b/plugins/a-exp.lv2/a-exp.ttl.in
++@@ -2,6 +2,7 @@
++ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
++ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
++ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
+++@prefix mod: <http://moddevices.com/ns/mod#> .
++ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
++ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
++ @prefix unit: <http://lv2plug.in/ns/extensions/units#> .
++@@ -173,6 +174,8 @@ A powerful mono expander
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:developer <http://ardour.org/credits.html> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in b/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
++index fd8cb18..90a8e7f 100644
++--- a/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
+++++ b/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
++@@ -33,6 +33,8 @@
++ doap:developer <http://ardour.org/credits.html> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++diff --git a/plugins/a-reverb.lv2/a-reverb.ttl.in b/plugins/a-reverb.lv2/a-reverb.ttl.in
++index 29e3125..339a61f 100644
++--- a/plugins/a-reverb.lv2/a-reverb.ttl.in
+++++ b/plugins/a-reverb.lv2/a-reverb.ttl.in
++@@ -20,6 +20,8 @@
++ doap:developer <http://ardour.org/credits.html> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++
+++ mod:brand "DISTRHO" ;
+++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
+diff --git a/plugins/a-comp.lv2/a-comp#stereo.ttl.in b/plugins/a-comp.lv2/a-comp#stereo.ttl.in
+index dd84c75..13f17c2 100644
+--- a/plugins/a-comp.lv2/a-comp#stereo.ttl.in
++++ b/plugins/a-comp.lv2/a-comp#stereo.ttl.in
+@@ -1,6 +1,7 @@
+ @prefix doap: <http://usefulinc.com/ns/doap#> .
+ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
+ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
++@prefix mod: <http://moddevices.com/ns/mod#> .
+ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
+ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
+ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
+@@ -185,5 +186,12 @@ A powerful stereo compressor.
+ doap:license "GPL v2+" ;
+ doap:developer <http://ardour.org/credits.html> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 2 .
+diff --git a/plugins/a-comp.lv2/a-comp.ttl.in b/plugins/a-comp.lv2/a-comp.ttl.in
+index 23adaa6..d36eaee 100644
+--- a/plugins/a-comp.lv2/a-comp.ttl.in
++++ b/plugins/a-comp.lv2/a-comp.ttl.in
+@@ -2,6 +2,7 @@
+ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
+ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
+ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
++@prefix mod: <http://moddevices.com/ns/mod#> .
+ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
+ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
+ @prefix unit: <http://lv2plug.in/ns/extensions/units#> .
+@@ -169,8 +170,15 @@ A powerful mono compressor.
+ """ ;
+
+ doap:name "DIE Compressor" ;
+- doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+ doap:developer <http://ardour.org/credits.html> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 2 .
+diff --git a/plugins/a-delay.lv2/a-delay.ttl.in b/plugins/a-delay.lv2/a-delay.ttl.in
+index c5c4ccd..1fc8ef2 100644
+--- a/plugins/a-delay.lv2/a-delay.ttl.in
++++ b/plugins/a-delay.lv2/a-delay.ttl.in
+@@ -3,6 +3,7 @@
+ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
+ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
+ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
++@prefix mod: <http://moddevices.com/ns/mod#> .
+ @prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
+ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
+ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
+@@ -183,5 +184,12 @@ A simple delay plugin
+ doap:license "GPL v2+" ;
+ doap:developer <http://ardour.org/credits.html> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 4 .
+diff --git a/plugins/a-eq.lv2/a-eq.ttl.in b/plugins/a-eq.lv2/a-eq.ttl.in
+index 44efb56..a55d151 100644
+--- a/plugins/a-eq.lv2/a-eq.ttl.in
++++ b/plugins/a-eq.lv2/a-eq.ttl.in
+@@ -2,6 +2,7 @@
+ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
+ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
+ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
++@prefix mod: <http://moddevices.com/ns/mod#> .
+ @prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
+ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
+ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
+@@ -311,5 +312,12 @@ A basic 4 band EQ.
+ doap:license "GPL v2+" ;
+ doap:developer <http://ardour.org/credits.html> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 2 .
+diff --git a/plugins/a-exp.lv2/a-exp#stereo.ttl.in b/plugins/a-exp.lv2/a-exp#stereo.ttl.in
+index 72bce7f..7d4abc4 100644
+--- a/plugins/a-exp.lv2/a-exp#stereo.ttl.in
++++ b/plugins/a-exp.lv2/a-exp#stereo.ttl.in
+@@ -2,6 +2,7 @@
+ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
+ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
+ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
++@prefix mod: <http://moddevices.com/ns/mod#> .
+ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
+ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
+ @prefix unit: <http://lv2plug.in/ns/extensions/units#> .
+@@ -175,8 +176,15 @@ A powerful stereo expander
+ """ ;
+
+ doap:name "DIE Expander (stereo)" ;
+- doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+ doap:developer <http://ardour.org/credits.html> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 2 .
+diff --git a/plugins/a-exp.lv2/a-exp.ttl.in b/plugins/a-exp.lv2/a-exp.ttl.in
+index b98c5fb..c455376 100644
+--- a/plugins/a-exp.lv2/a-exp.ttl.in
++++ b/plugins/a-exp.lv2/a-exp.ttl.in
+@@ -2,6 +2,7 @@
+ @prefix foaf: <http://xmlns.com/foaf/0.1/> .
+ @prefix idpy: <http://harrisonconsoles.com/lv2/inlinedisplay#> .
+ @prefix lv2: <http://lv2plug.in/ns/lv2core#> .
++@prefix mod: <http://moddevices.com/ns/mod#> .
+ @prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
+ @prefix rsz: <http://lv2plug.in/ns/ext/resize-port#> .
+ @prefix unit: <http://lv2plug.in/ns/extensions/units#> .
+@@ -170,8 +171,15 @@ A powerful mono expander
+ """ ;
+
+ doap:name "DIE Expander" ;
+- doap:license <http://usefulinc.com/doap/licenses/gpl> ;
++ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+ doap:developer <http://ardour.org/credits.html> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 2 .
+diff --git a/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in b/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
+index b96e947..90a8e7f 100644
+--- a/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
++++ b/plugins/a-fluidsynth.lv2/a-fluidsynth.ttl.in
+@@ -33,6 +33,13 @@
+ doap:developer <http://ardour.org/credits.html> ;
+ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 2 ;
+ lv2:minorVersion 2 ;
+
+diff --git a/plugins/a-reverb.lv2/a-reverb.ttl.in b/plugins/a-reverb.lv2/a-reverb.ttl.in
+index 66e1a91..339a61f 100644
+--- a/plugins/a-reverb.lv2/a-reverb.ttl.in
++++ b/plugins/a-reverb.lv2/a-reverb.ttl.in
+@@ -20,6 +20,13 @@
+ doap:developer <http://ardour.org/credits.html> ;
+ doap:license <http://usefulinc.com/doap/licenses/gpl> ;
+
++ mod:brand "DISTRHO" ;
++
++ doap:maintainer [
++ foaf:name "DISTRHO" ;
++ foaf:homepage <https://github.com/DISTRHO/DIE-Plugins> ;
++ ] ;
++
+ lv2:microVersion 4 ;
+ lv2:minorVersion 2 ;
+ lv2:optionalFeature lv2:hardRTCapable ;