summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 20:15:29 +0100
committerBartłomiej Piotrowski2018-01-06 20:15:29 +0100
commitc31e147e7c2b927d00cb812447a4d70de183963e (patch)
tree92075c598d9adfb40d623b9165ee7b4f9208ef83
downloadaur-diff2html.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1ad2fe542d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = diff2html
+ pkgdesc = diff to html
+ pkgver = 1.0.1
+ pkgrel = 5
+ url = http://kafka.fr.free.fr/spip.php?article4
+ arch = any
+ license = GPL
+ depends = python2
+ source = http://kafka.fr.free.fr/files/diff2html/diff2html.bz2
+ md5sums = e3aa3bd4fec0a93f5f97efcd210e232b
+
+pkgname = diff2html
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a99203b4881
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 194152 2016-10-31 13:48:24Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=diff2html
+pkgver=1.0.1
+pkgrel=5
+pkgdesc="diff to html"
+arch=(any)
+url="http://kafka.fr.free.fr/spip.php?article4"
+license=('GPL')
+depends=(python2)
+makedepends=()
+#source=(http://arch.p5n.pp.ru/~sergej/dl/2014/diff2html.bz2)
+source=(http://kafka.fr.free.fr/files/diff2html/diff2html.bz2)
+md5sums=('e3aa3bd4fec0a93f5f97efcd210e232b')
+
+build() {
+ sed -i 's_#!/usr/bin/python_#!/usr/bin/python2_' "$srcdir"/$pkgname
+}
+
+package() {
+ install -D -m0755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}