summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 15:34:57 +0200
committerPiotr Rogoża2015-06-14 15:34:57 +0200
commit10c161da4160c52f720b2d6f4612f7f9cd74ce5a (patch)
tree716767cb6e5a820af0ff07b089791193fad6ac6b
downloadaur-10c161da4160c52f720b2d6f4612f7f9cd74ce5a.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
-rw-r--r--diffimg.desktop10
-rw-r--r--diffimg.install14
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad3bb5b31f2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = diffimg
+ pkgdesc = Simple image comparison tool
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/diffimg/
+ install = diffimg.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = qt4
+ makedepends = qwt
+ makedepends = opencv
+ depends = qt4
+ depends = qwt
+ depends = opencv
+ source = http://sourceforge.net/projects/diffimg/files/2.0.1/diffimg-2.0.1.zip
+ source = diffimg.desktop
+ md5sums = 1b60f8d121761b8b77fe152a3fbd5639
+ md5sums = 1f924268b20847374b6b260f2b7f1f7d
+
+pkgname = diffimg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..745835332178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Nathan O <ndowens.aur at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+
+pkgname=diffimg
+_pkgname=DiffImg
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Simple image comparison tool"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=(qt4 qwt opencv)
+makedepends=(qt4 qwt opencv)
+url='http://sourceforge.net/projects/diffimg/'
+source=(
+"http://sourceforge.net/projects/diffimg/files/${pkgver}/diffimg-${pkgver}.zip"
+diffimg.desktop
+)
+install='diffimg.install'
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i -e 's/\r//' \
+ -e 's/|/-print0 |/' \
+ -e "s#dos2unix#-0 sed -i 's|\\\r||'#" \
+ tounix.sh
+ sh ./tounix.sh
+
+ cd ./build
+ qmake-qt4 -recursive INSTALL_PREFIX=/usr diffimg.pro
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ cd ./build
+ make INSTALL_ROOT="${pkgdir}" install
+
+# install -dm755 "$pkgdir"/usr/share/icons
+# ln -s ../pixmaps/res/diffimg.ico "$pkgdir"/usr/share/icons/diffimg.ico
+ # fix conflicts with graphviz
+ mv "$pkgdir"/usr/bin/$pkgname "$pkgdir"/usr/bin/${_pkgname}
+ mv "$pkgdir"/usr/share/man/man1/$pkgname.1.gz "$pkgdir"/usr/share/man/man1/${_pkgname}.1.gz
+}
+md5sums=('1b60f8d121761b8b77fe152a3fbd5639'
+ '1f924268b20847374b6b260f2b7f1f7d')
diff --git a/diffimg.desktop b/diffimg.desktop
new file mode 100644
index 000000000000..e12f7277d76e
--- /dev/null
+++ b/diffimg.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=DiffImg
+Comment=Simple image comparison tool
+Exec=DiffImg
+Icon=/usr/share/pixmaps/res/diffimg.ico
+Terminal=false
+StartupNotify=false
+Categories=Application;Graphics
diff --git a/diffimg.install b/diffimg.install
new file mode 100644
index 000000000000..c1c351307e9e
--- /dev/null
+++ b/diffimg.install
@@ -0,0 +1,14 @@
+post_install(){
+ echo "Program diffimg (and man page) has been renamed as DiffImg because it conflicts with graphviz"
+ #which xdg-icon-resource >/dev/null 2>&1 && xdg-icon-resource forceupdate || true
+ echo "update desktop mime database..."
+ update-desktop-database -q
+}
+post_upgrade(){
+ post_install
+}
+post_remove(){
+ #which xdg-icon-resource >/dev/null 2>&1 && xdg-icon-resource forceupdate || true
+ echo "update desktop mime database..."
+ update-desktop-database -q
+}