summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuan_k2018-09-20 03:21:39 +0200
committerfuan_k2018-09-20 03:21:39 +0200
commit406d2672968626b60997c723c12bb53e0a8c3604 (patch)
treeece5a5898c0beb0227fc34f7a1d8adc678874068
parent2575c05b59f27b9e901465b59ddcc1b4e53737f5 (diff)
downloadaur-406d2672968626b60997c723c12bb53e0a8c3604.tar.gz
Fix redundant cmake and renaming of man, removed makedeps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57f7cd9fe3ba..485877dac1f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,9 +7,6 @@ pkgbase = diffimg
arch = i686
arch = x86_64
license = GPL2
- makedepends = qt4
- makedepends = qwt-qt4
- makedepends = opencv
makedepends = cmake
depends = qt4
depends = qwt-qt4
@@ -21,3 +18,4 @@ pkgbase = diffimg
md5sums = 98d6aae50942ef908313515bdd9b02f4
pkgname = diffimg
+
diff --git a/PKGBUILD b/PKGBUILD
index 4899df31c046..aed1e02307b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ arch=('i686' 'x86_64')
license=('GPL2')
depends=(qt4 qwt-qt4 opencv)
optdepends=(freeimage)
-makedepends=(qt4 qwt-qt4 opencv cmake)
+makedepends=(cmake)
url='http://sourceforge.net/projects/diffimg/'
source=(
"http://sourceforge.net/projects/diffimg/files/${pkgver}/${_pkgname}-${pkgver}-src.zip"
@@ -43,7 +43,6 @@ build() {
#qmake-qt4 -recursive INSTALL_PREFIX=/usr diffimg.pro
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr .
#cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}" . #for makechrootpkg -r $CHROOT -- ief
- cmake .
make
}
@@ -64,7 +63,7 @@ package() {
#install -Dm755 ./usr/bin/${pkgname} "${pkgdir}"/usr/bin/${_pkgname}
mv "${pkgdir}/usr/bin/${pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${pkgdir}/usr/share/man/man1/${pkgname}.1.gz" "${pkgdir}"/usr/share/man/man1/${_pkgname}.1.gz
+ #install -Dm644 "${pkgdir}/usr/share/man/man1/${pkgname}.1.gz" "${pkgdir}"/usr/share/man/man1/${_pkgname}.1.gz
mv "${pkgdir}/usr/share/man/man1/${pkgname}.1.gz" "${pkgdir}/usr/share/man/man1/${_pkgname}.1.gz"
install -Dm644 ../res/diffimg.ico "$pkgdir"/usr/share/pixmaps/${_pkgname}/${_pkgname}.ico