summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2019-12-21 18:30:34 +0100
committerMartin T. H. Sandsmark2019-12-21 18:30:34 +0100
commit17d2914573e4e32d59b2c23c569ae974428a8cda (patch)
treee9402213f84c5f0d7fa8ee44c9931959ff627be4
downloadaur-17d2914573e4e32d59b2c23c569ae974428a8cda.tar.gz
initial
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03d87acfa83d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = diffimg-git
+ pkgdesc = Qt based GUI to diff images
+ pkgver = r51.58bc07f
+ pkgrel = 1
+ url = https://github.com/sandsmark/diffimg
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ depends = qwt
+ depends = opencv
+ provides = diffimg
+ conflicts = diffimg
+ source = git://github.com/sandsmark/diffimg.git
+ md5sums = SKIP
+
+pkgname = diffimg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebad55cd4e49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=diffimg-git
+pkgver=r51.58bc07f
+pkgrel=1
+pkgdesc='Qt based GUI to diff images'
+arch=('i686' 'x86_64')
+url='https://github.com/sandsmark/diffimg'
+license=('GPL')
+depends=('qt5-base' 'qwt' 'opencv')
+makedepends=('git')
+conflicts=(diffimg)
+provides=(diffimg)
+source=('git://github.com/sandsmark/diffimg.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd diffimg
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd diffimg
+ qmake
+ make
+}
+
+package() {
+ cd diffimg
+ make INSTALL_ROOT="$pkgdir" install
+ mv "$pkgdir"/usr/bin/diffimg "$pkgdir"/usr/bin/diffimg-qt
+ mv "$pkgdir"/usr/share/man/man1/diffimg.1.gz "$pkgdir"/usr/share/man/man1/diffimg-qt.1.gz
+}