summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSevenseven2017-06-27 16:01:01 +0300
committerSevenseven2017-06-27 16:01:01 +0300
commit548892446610c08d60df95bdf2b29d8ac8c7086c (patch)
tree2b9aa20d0301b68b63f19feb1e16dc221914697e
parenta0bb97cf150ec59323b0310ea73d1007df80a1db (diff)
downloadaur-548892446610c08d60df95bdf2b29d8ac8c7086c.tar.gz
fix qtav
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b41bc7d98df4..25161b3e5513 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = digikam-git
pkgdesc = Digital photo management application for KDE
- pkgver = r35552.3da1520f9c
+ pkgver = r36468.5efd13702a
pkgrel = 1
url = http://www.digikam.org/
install = digikam-git.install
@@ -15,21 +15,20 @@ pkgbase = digikam-git
makedepends = boost
makedepends = mariadb
makedepends = kdoctools
- makedepends = qtav
- depends = libkipi-git
- depends = knotifyconfig
- depends = kfilemetadata
- depends = libgphoto2
+ depends = marble-common
+ depends = libksane-git
depends = liblqr
+ depends = libkipi-git
+ depends = kcalcore
+ depends = qtav
depends = lensfun
- depends = qt5-multimedia
+ depends = knotifyconfig
depends = akonadi-contacts
- depends = libksane-git
+ depends = kfilemetadata
+ depends = opencv
depends = threadweaver
- depends = kcalcore
- optdepends = kipi-plugins: more tools and plugins
+ optdepends = kipi-plugins-git: more tools and plugins
optdepends = hugin: panorama tool
- optdepends = qtav: Media Player support
provides = digikam
conflicts = digikam
source = digikam::git+git://anongit.kde.org/digikam
diff --git a/PKGBUILD b/PKGBUILD
index 9a6d662e4009..75b3ebbdfc10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
pkgname=digikam-git
-pkgver=r35552.3da1520f9c
+pkgver=r36468.5efd13702a
pkgrel=1
pkgdesc='Digital photo management application for KDE'
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.digikam.org/"
-depends=('libkipi-git' 'knotifyconfig' 'kfilemetadata' 'libgphoto2' 'liblqr' 'lensfun' \
- 'qt5-multimedia' 'akonadi-contacts' 'libksane-git' 'threadweaver' 'kcalcore')
-makedepends=('git' 'extra-cmake-modules-git' 'eigen' 'doxygen' 'boost' 'mariadb' 'kdoctools' 'qtav')
-optdepends=('kipi-plugins: more tools and plugins'
- 'hugin: panorama tool'
- 'qtav: Media Player support')
+depends=('marble-common' 'libksane-git' 'liblqr' 'libkipi-git' 'kcalcore' 'qtav' 'lensfun' 'knotifyconfig' 'akonadi-contacts' 'kfilemetadata' 'opencv' 'threadweaver')
+makedepends=('git' 'extra-cmake-modules-git' 'eigen' 'doxygen' 'boost' 'mariadb' 'kdoctools')
+optdepends=('kipi-plugins-git: more tools and plugins'
+ 'hugin: panorama tool')
conflicts=('digikam')
provides=('digikam')
install=digikam-git.install
@@ -39,8 +37,7 @@ build() {
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF -DENABLE_AKONADICONTACTSUPPORT=ON -DENABLE_KFILEMETADATASUPPORT=ON \
-DENABLE_MYSQLSUPPORT=ON -DENABLE_INTERNALMYSQL=ON -DENABLE_MEDIAPLAYER=ON \
- -DENABLE_OPENCV3=ON -DENABLE_APPSTYLES=ON \
- -DQTAV_CORE_INCLUDE_DIR:PATH="/usr/include/qt/" -DQTAV_WIDGETS_INCLUDE_DIR:PATH="/usr/include/qt/"
+ -DENABLE_OPENCV3=ON -DENABLE_APPSTYLES=ON
make
}