summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchuvke2017-07-02 15:59:09 +0200
committerchuvke2017-07-02 15:59:09 +0200
commitc2796d036ebcdd561dc6be5a541df55a1626e7e4 (patch)
tree734b41c2feb75521b1609774119bb14bfa73bc29
downloadaur-c2796d036ebcdd561dc6be5a541df55a1626e7e4.tar.gz
Initial revision
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--digilent-agent.install10
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91c4ea39e2e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = digilent-agent
+ pkgdesc = enables browser based applications to communicate with Digilent hardware (e.g. the OpenScopeMZ)
+ pkgver = 6e2057e
+ pkgrel = 1
+ url = https://github.com/Digilent/digilent-agent
+ install = digilent-agent.install
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-serialport
+ source = digilent-agent::git+https://github.com/Digilent/digilent-agent.git#commit=6e2057e441c650fbd522a6033c2810386363941f
+ sha256sums = SKIP
+
+pkgname = digilent-agent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdde8d913e51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: chuvke <chuvke AT gmail DOT com>
+pkgname=digilent-agent
+pkgver=6e2057e
+_pkgrevision=6e2057e441c650fbd522a6033c2810386363941f
+pkgrel=1
+epoch=
+pkgdesc="enables browser based applications to communicate with Digilent hardware (e.g. the OpenScopeMZ)"
+arch=('i686' 'x86_64')
+url="https://github.com/Digilent/digilent-agent"
+license=('LGPL3')
+depends=(qt5-base qt5-serialport)
+makedepends=(git)
+install="${pkgname}.install"
+source=("$pkgname::git+$url.git#commit=$_pkgrevision")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ qmake
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 775 "digilent-agent" "${pkgdir}/usr/bin/digilent-agent"
+}
diff --git a/digilent-agent.install b/digilent-agent.install
new file mode 100644
index 000000000000..56ecb0b8e1f8
--- /dev/null
+++ b/digilent-agent.install
@@ -0,0 +1,10 @@
+## arg 1: the new package version
+post_install() {
+ echo "
+You need to add youself to the 'uucp' usergroup to be able connect to the
+serial ports. Use something like this:
+
+ sudo usermod -aG uucp <your username>
+
+"
+}