summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2018-11-17 18:23:39 -0600
committercyrozap2018-11-17 18:23:39 -0600
commit24ad9dfefeb5c8e2903c6a3feec45f1d9d3e3df9 (patch)
treedec71704c61c089f94e39eb07cbc0f78b6f38d35
parentb48ff94e2e6de4e76f51a4ffc50f47bed37cea6f (diff)
downloadaur-24ad9dfefeb5c8e2903c6a3feec45f1d9d3e3df9.tar.gz
Fixed 2.18.3 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd9dedfabce0..a57140753441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = digilent.adept.runtime
pkgdesc = The Adept Runtime consists of the shared libraries, firmware images, and configuration files necessary to communicate with Digilent's devices.
- pkgver = 2.19.2
+ pkgver = 2.18.3
pkgrel = 1
url = https://reference.digilentinc.com/reference/software/adept/start
arch = i686
@@ -14,14 +14,12 @@ pkgbase = digilent.adept.runtime
backup = etc/digilent-adept.conf
backup = etc/ld.so.conf.d/digilent-adept-libraries.conf
backup = etc/udev/rules.d/52-digilent-usb.rules
- source_i686 = https://files.digilent.com/Software/Adept2+Runtime/2.19.2/digilent.adept.runtime_2.19.2-i386.deb
- sha256sums_i686 = 9ea59e3f7e3cc84cea8117f73bef744cf19b5568d160888ce823570683bbcfc6
- source_x86_64 = https://files.digilent.com/Software/Adept2+Runtime/2.19.2/digilent.adept.runtime_2.19.2-amd64.deb
- sha256sums_x86_64 = 7fb2a11a874dc6c93629abceeb6a496bcead651d23e3a65b14ef62b3a4191924
- source_armv6h = https://files.digilent.com/Software/Adept2+Runtime/2.19.2/digilent.adept.runtime_2.19.2-armhf.deb
- sha256sums_armv6h = 629b41d66f2953def54d5c60625501653c08cd6250029a76ad2d6c6c52aa3523
- source_armv7h = https://files.digilent.com/Software/Adept2+Runtime/2.19.2/digilent.adept.runtime_2.19.2-armhf.deb
- sha256sums_armv7h = 629b41d66f2953def54d5c60625501653c08cd6250029a76ad2d6c6c52aa3523
+ source_i686 = https://files.digilent.com/Software/Adept2+Runtime/2.18.3/digilent.adept.runtime_2.18.3-i386.deb
+ sha256sums_i686 = bf2fecc538d0f3e558409212682b0c46f33122614dcfc6977fb58c0e4f8d3199
+ source_x86_64 = https://files.digilent.com/Software/Adept2+Runtime/2.18.3/digilent.adept.runtime_2.18.3-amd64.deb
+ sha256sums_x86_64 = 207d55e4176acf65bbfc1522d006fce69aba564422e7a0921bea74dea49573fd
+ source_armv6h = https://files.digilent.com/Software/Adept2+Runtime/2.18.3/digilent.adept.runtime_2.18.3-armhf.deb
+ source_armv7h = https://files.digilent.com/Software/Adept2+Runtime/2.18.3/digilent.adept.runtime_2.18.3-armhf.deb
pkgname = digilent.adept.runtime
diff --git a/PKGBUILD b/PKGBUILD
index 38f6ac1095b9..9cd3dd13c4f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=digilent.adept.runtime
-pkgver=2.19.2
+pkgver=2.18.3
pkgrel=1
pkgdesc="The Adept Runtime consists of the shared libraries, firmware images, and configuration files necessary to communicate with Digilent's devices."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -15,14 +15,14 @@ source_armv6h=("https://files.digilent.com/Software/Adept2+Runtime/${pkgver}/${p
source_armv7h=($source_armv6h)
source_i686=("https://files.digilent.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-i386.deb")
source_x86_64=("https://files.digilent.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-amd64.deb")
-sha256sums_armv6h=('629b41d66f2953def54d5c60625501653c08cd6250029a76ad2d6c6c52aa3523')
+sha256sums_armv6h=('') # The file doesn't seem to exist.
sha256sums_armv7h=($sha256sums_armv6h)
-sha256sums_i686=('9ea59e3f7e3cc84cea8117f73bef744cf19b5568d160888ce823570683bbcfc6')
-sha256sums_x86_64=('7fb2a11a874dc6c93629abceeb6a496bcead651d23e3a65b14ef62b3a4191924')
+sha256sums_i686=('bf2fecc538d0f3e558409212682b0c46f33122614dcfc6977fb58c0e4f8d3199')
+sha256sums_x86_64=('207d55e4176acf65bbfc1522d006fce69aba564422e7a0921bea74dea49573fd')
package() {
# Extract
- tar -xzf data.tar.gz --exclude="usr/share/lintian" -C "${pkgdir}"/
+ tar -xJf data.tar.xz --exclude="usr/share/lintian" -C "${pkgdir}"/
# Correct paths
[ -d "${pkgdir}"/usr/lib64 ] && mv "${pkgdir}"/usr/{lib64,lib}