summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2015-09-05 20:40:34 -0400
committercyrozap2015-09-05 20:40:34 -0400
commit7f5d2459c83e50578ecf720aded52c3f818f6370 (patch)
tree80e5a253570bec6529492ae88ff5add82af1c329
parentca3857cbeb2e6f83e656685241b154be9df68539 (diff)
downloadaur-7f5d2459c83e50578ecf720aded52c3f818f6370.tar.gz
Replaced architecture hack and removed weaker checksums
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af837000caef..17d51ff5c2b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,10 @@ pkgbase = digilent.adept.runtime
backup = etc/digilent-adept.conf
backup = etc/ld.so.conf.d/digilent-adept-libraries.conf
backup = etc/udev/rules.d/52-digilent-usb.rules
+ source_i686 = http://www.digilentinc.com/Data/Products/ADEPT2/digilent.adept.runtime_2.16.1_i386.deb
+ sha256sums_i686 = da3f3e41c66120c2799768a10c3c9cc956e0d7068ddbe104a09f78b299e856f3
+ source_x86_64 = http://www.digilentinc.com/Data/Products/ADEPT2/digilent.adept.runtime_2.16.1_amd64.deb
+ sha256sums_x86_64 = 45f66f9803cad62fa6c4468903e12556c66ee95dd433f1c6e91cadca44e50679
pkgname = digilent.adept.runtime
diff --git a/PKGBUILD b/PKGBUILD
index 26128c90c6ad..6b119f1af47f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,16 +11,10 @@ depends=('libusb')
conflicts=('libftd2xx')
options=('!strip')
backup=('etc/digilent-adept.conf' 'etc/ld.so.conf.d/digilent-adept-libraries.conf' 'etc/udev/rules.d/52-digilent-usb.rules')
-
-if [[ $CARCH == 'i686' ]]; then
- source=("http://www.digilentinc.com/Data/Products/ADEPT2/${pkgname}_${pkgver}_i386.deb")
- sha1sums=('42d939af49701ffefc229720d45c47be7d1e1860')
- sha256sums=('da3f3e41c66120c2799768a10c3c9cc956e0d7068ddbe104a09f78b299e856f3')
-elif [[ $CARCH == 'x86_64' ]]; then
- source=("http://www.digilentinc.com/Data/Products/ADEPT2/${pkgname}_${pkgver}_amd64.deb")
- sha1sums=('34968e47627b8f5dc3d92bcfb9e49e601c6fcfa1')
- sha256sums=('45f66f9803cad62fa6c4468903e12556c66ee95dd433f1c6e91cadca44e50679')
-fi
+source_i686=("http://www.digilentinc.com/Data/Products/ADEPT2/${pkgname}_${pkgver}_i386.deb")
+source_x86_64=("http://www.digilentinc.com/Data/Products/ADEPT2/${pkgname}_${pkgver}_amd64.deb")
+sha256sums_i686=('da3f3e41c66120c2799768a10c3c9cc956e0d7068ddbe104a09f78b299e856f3')
+sha256sums_x86_64=('45f66f9803cad62fa6c4468903e12556c66ee95dd433f1c6e91cadca44e50679')
package() {
# Extract