summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMcKay Humpherys2022-03-03 17:49:09 -0700
committerMcKay Humpherys2022-03-03 17:49:09 -0700
commit42f3fdd61f0afef64fbbb10d7fd9b5b1bd104439 (patch)
tree3e4d66d2f7d232eacb40f610c3fd259198feeef1
downloadaur-42f3fdd61f0afef64fbbb10d7fd9b5b1bd104439.tar.gz
New PKGBUILD script for installing digitalwatchdog-client
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD24
-rw-r--r--digitalwatchdog-client.install32
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9e96e0d9e94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = digitalwatchdog-client
+ pkgdesc = DW Spectrum Client
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = http://completeipsolution.com
+ install = digitalwatchdog-client.install
+ arch = x86_64
+ groups =
+ license = Proprietary
+ depends = alsa-lib
+ depends = dbus
+ depends = fontconfig
+ depends = freetype2>=2.6.0
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = glu
+ depends = libegl
+ depends = libgl
+ depends = libglvnd
+ depends = libpulse
+ depends = libsecret
+ depends = libx11
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxfixes
+ depends = libxi
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = openal
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-webchannel
+ depends = qt5-webengine
+ depends = systemd-libs
+ depends = zlib>=1.1.4
+ optdepends = binutils
+ replaces = digitalwatchdog-client-1.2<4.2.0
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://digital-watchdog.com/_gendownloads/3a136a16-d403-4478-bc9a-6f9795ca65f8/dwspectrum-client-4.2.0.32842-linux64.deb
+ sha512sums_x86_64 = 0551d8917ba031e81b9a2ca599d86c37ab5d3ca02f5f22e28dcf0a9bf7fe1575ac66258c2d23f438efb026753f9c740b97261ecdfff40cf0a67344349acdaf58
+
+pkgname = digitalwatchdog-client
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..437ce15c7abf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: McKay Humpherys <mckaybhumpherys@gmail.com>
+# Contributor: McKay
+pkgname=digitalwatchdog-client
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="DW Spectrum Client"
+arch=('x86_64')
+url="http://completeipsolution.com"
+license=('Proprietary')
+groups=('')
+depends=('alsa-lib' 'dbus' 'fontconfig' 'freetype2>=2.6.0' 'gcc-libs' 'glib2' 'glibc' 'glu' 'libegl' 'libgl' 'libglvnd' 'libpulse' 'libsecret' 'libx11' 'libxcomposite' 'libxcursor' 'libxfixes' 'libxi' 'libxkbcommon' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'openal' 'qt5-base' 'qt5-declarative' 'qt5-webchannel' 'qt5-webengine' 'systemd-libs' 'zlib>=1.1.4')
+optdepends=('binutils')
+replaces=('digitalwatchdog-client-1.2<4.2.0')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://digital-watchdog.com/_gendownloads/3a136a16-d403-4478-bc9a-6f9795ca65f8/dwspectrum-client-4.2.0.32842-linux64.deb")
+sha512sums_x86_64=('0551d8917ba031e81b9a2ca599d86c37ab5d3ca02f5f22e28dcf0a9bf7fe1575ac66258c2d23f438efb026753f9c740b97261ecdfff40cf0a67344349acdaf58')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/digitalwatchdog-client.install b/digitalwatchdog-client.install
new file mode 100644
index 000000000000..23a863d77879
--- /dev/null
+++ b/digitalwatchdog-client.install
@@ -0,0 +1,32 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+
+ COMPANY_NAME=digitalwatchdog
+ FULLVERSION=4.2.0.32842
+ TARGET=/opt/$COMPANY_NAME/client/$FULLVERSION
+
+
+ if [ -n "$DEBIAN_SCRIPT_DEBUG" ]; then set -v -x; DEBIAN_SCRIPT_TRACE=1; fi
+ ${DEBIAN_SCRIPT_TRACE:+ echo "#42#DEBUG# RUNNING $0 $*" 1>&2 }
+
+ pkill applauncher-bin || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+
+
+ if [ -n "$DEBIAN_SCRIPT_DEBUG" ]; then set -v -x; DEBIAN_SCRIPT_TRACE=1; fi
+ ${DEBIAN_SCRIPT_TRACE:+ echo "#42#DEBUG# RUNNING $0 $*" 1>&2 }
+
+ pkill applauncher-bin || true
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}