summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Beaumont2020-08-05 11:00:32 +0200
committerMichael Beaumont2020-08-05 11:09:28 +0200
commit746fbbb6f9d2e970353a13d34349eb6203ead7ad (patch)
treef24998b1e2205adcb837b6bce50096c067724d22
downloadaur-746fbbb6f9d2e970353a13d34349eb6203ead7ad.tar.gz
Release v0.2.3
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81102268c705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dijo-bin
+ pkgdesc = Scriptable, curses-based, digital habit tracker
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/NerdyPepper/dijo
+ arch = x86_64
+ license = MIT
+ depends = gcc-libs
+ provides = dijo=0.2.3
+ conflicts = dijo-git
+ source = dijo-0.2.3-x86_64::https://github.com/NerdyPepper/dijo/releases/download/v0.2.3/dijo-x86_64-linux
+ source = LICENSE-0.2.3::https://raw.githubusercontent.com/NerdyPepper/dijo/v0.2.3/LICENSE
+ sha256sums = f1cb407a18dc6078f2cfd9bf2cf20b276224c7c6a9926cd11aa3178748abc53a
+ sha256sums = fd1dd686de8dc3d27fae79efdf74656b6237aa948296d6a2fe55bdc18b7cc9e1
+
+pkgname = dijo-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2394c3fdd135
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar*
+LICENSE*
+dijo*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5901bc1ba3cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michael Beaumont <mjboamail@gmail.com>
+# URL: https://github.com/michaelbeaumont/aur-packages
+_pkgname=dijo
+pkgname=${_pkgname}-bin
+pkgdesc="Scriptable, curses-based, digital habit tracker"
+pkgver=0.2.3
+pkgrel=1
+arch=(x86_64)
+_repo=NerdyPepper/dijo
+url="https://github.com/${_repo}"
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}-git")
+license=(MIT)
+depends=(gcc-libs)
+_binname="${_pkgname}-${pkgver}-${arch}"
+source=(
+ "${_binname}::${url}/releases/download/v${pkgver}/${_pkgname}-$arch-linux"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/${_repo}/v${pkgver}/LICENSE"
+)
+sha256sums=(
+ f1cb407a18dc6078f2cfd9bf2cf20b276224c7c6a9926cd11aa3178748abc53a
+ fd1dd686de8dc3d27fae79efdf74656b6237aa948296d6a2fe55bdc18b7cc9e1
+)
+
+package() {
+ install -dm755 "$pkgdir/usr/share/licenses/${pkgname}/"
+ cd "${srcdir}"
+ install -m644 LICENSE-${pkgver} "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 ${_binname} ${pkgdir}/usr/bin/${_pkgname}
+}