summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpunkeroso2016-01-02 11:58:06 +0100
committerpunkeroso2016-01-02 11:58:06 +0100
commitf1607b60badacaac6a83cdf26a349dfb972442c5 (patch)
tree5a7e2d683fbe124ae13c73054b0e1f09e760c96c
downloadaur-f1607b60badacaac6a83cdf26a349dfb972442c5.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
-rw-r--r--dimdaemon.install8
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4ef7bb646bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 10:55:24 UTC 2016
+pkgbase = dimdaemon
+ pkgdesc = A simple and lightweight backlight-dimming daemon for laptops
+ pkgver = 0.5
+ pkgrel = 2
+ url = https://bbs.archlinux.org/viewtopic.php?pid=1028685
+ install = dimdaemon.install
+ arch = i686
+ arch = x86_64
+ groups = daemons
+ license = GPL3
+ depends = xorg-server
+ depends = libconfig
+ depends = libxext
+ depends = libxss
+ backup = etc/conf.d/dimdaemon.conf
+ source = http://dl.dropbox.com/u/25456252/dimdaemon-0.5.tar.gz
+ md5sums = 17a3df5319c6d351dfaeef812c3c9584
+
+pkgname = dimdaemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d33a5521793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Francesco Antonacci <punkeroso at gmail dot com>
+
+pkgname=dimdaemon
+pkgver=0.5
+pkgrel=2
+pkgdesc="A simple and lightweight backlight-dimming daemon for laptops"
+arch=(i686 x86_64)
+license=('GPL3')
+url="https://bbs.archlinux.org/viewtopic.php?pid=1028685"
+groups=('daemons')
+depends=('xorg-server' 'libconfig' 'libxext' 'libxss')
+backup=('etc/conf.d/dimdaemon.conf')
+install=$pkgname.install
+source=(http://dl.dropbox.com/u/25456252/$pkgname-$pkgver.tar.gz)
+md5sums=('17a3df5319c6d351dfaeef812c3c9584')
+
+build() {
+ cd $srcdir/$pkgname
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make
+ install -D -m755 dimdaemon $pkgdir/usr/bin/dimdaemon
+ install -D -m755 dimdaemond $pkgdir/etc/rc.d/dimdaemond
+ install -D -m644 dimdaemon.conf $pkgdir/etc/conf.d/dimdaemon.conf
+ install -D -m644 dimdaemon.service $pkgdir/usr/lib/systemd/system/dimdaemon.service
+}
diff --git a/dimdaemon.install b/dimdaemon.install
new file mode 100644
index 000000000000..e73fc12c1403
--- /dev/null
+++ b/dimdaemon.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Don't forget to set your home directory in /etc/conf.d/dimdaemon.conf and enable dimdaemon to start at boot by issuing systemd enable dimdaemon.service."
+ echo "If you sill use rc.d instead you can add dimdaemond to the DAEMONS array in your rc.conf."
+}
+post_upgrade() {
+ echo "If you want dimdaemon to start at boot, enable it by issuing systemctl enable dimdaemon.service."
+ echo "If you sill use rc.d instead you can add dimdaemond to the DAEMONS array in your rc.conf."
+}