summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2021-03-11 01:04:09 +0100
committerJoan Bruguera2021-03-11 01:04:09 +0100
commit2c856411dad8f0b302ef016b7a38ae99808c0e52 (patch)
treecbc41f7f7719800a2831dfd5b42e518c33a1e630
parent51054de64f70ecd0c6ab6b3251cf780c39ff9015 (diff)
downloadaur-2c856411dad8f0b302ef016b7a38ae99808c0e52.tar.gz
Remove GCC 10 patch since problem appears to be solved upstream - my previous pkgrel was botched.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--dimemas-Build-fix-for-GCC-10-fno-common-default.patch141
3 files changed, 4 insertions, 155 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b0ec1f9f7e2..ec4a75effcf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = dimemas
pkgdesc = High-abstracted network simulator for message-passing programs (from BSC).
pkgver = 5.4.2.20210310
- pkgrel = 1
+ pkgrel = 2
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
license = LGPL2.1
depends = boost
source = https://ftp.tools.bsc.es/dimemas/dimemas-5.4.2-src.tar.bz2
- source = dimemas-Build-fix-for-GCC-10-fno-common-default.patch
sha512sums = 5fe41152c583d2d4bc08ab939f9ca5f7599a4dc414cc6445db2fecf13093322f9f6ab9ef84411337fe9e3854bef40181830bc9a7e5319d86deb3fc1c0d0061d4
- sha512sums = 94b11bec6ee99fc9327a0f392d021289a1a5bb2150f2354a4403002fafe3263e18c7bfed8eee97fe26280813a84820565e5b0969b8dedf05c3852e2ab2634547
pkgname = dimemas
diff --git a/PKGBUILD b/PKGBUILD
index b34cb711e593..9682444d35ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,13 @@
pkgname='dimemas'
pkgdesc='High-abstracted network simulator for message-passing programs (from BSC).'
pkgver='5.4.2.20210310'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(boost)
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
- "dimemas-Build-fix-for-GCC-10-fno-common-default.patch")
-sha512sums=(5fe41152c583d2d4bc08ab939f9ca5f7599a4dc414cc6445db2fecf13093322f9f6ab9ef84411337fe9e3854bef40181830bc9a7e5319d86deb3fc1c0d0061d4
- 94b11bec6ee99fc9327a0f392d021289a1a5bb2150f2354a4403002fafe3263e18c7bfed8eee97fe26280813a84820565e5b0969b8dedf05c3852e2ab2634547)
-
-prepare() {
- cd "$srcdir/$pkgname-${pkgver%.*}"
-
- patch -Np1 -i "$srcdir/dimemas-Build-fix-for-GCC-10-fno-common-default.patch"
-}
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2")
+sha512sums=(5fe41152c583d2d4bc08ab939f9ca5f7599a4dc414cc6445db2fecf13093322f9f6ab9ef84411337fe9e3854bef40181830bc9a7e5319d86deb3fc1c0d0061d4)
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
diff --git a/dimemas-Build-fix-for-GCC-10-fno-common-default.patch b/dimemas-Build-fix-for-GCC-10-fno-common-default.patch
deleted file mode 100644
index ca79c02d7061..000000000000
--- a/dimemas-Build-fix-for-GCC-10-fno-common-default.patch
+++ /dev/null
@@ -1,141 +0,0 @@
-From 6d4a89a3d6a6767ad88b74933f060d0891c248b0 Mon Sep 17 00:00:00 2001
-From: Joan Bruguera <joanbrugueram@gmail.com>
-Date: Tue, 12 May 2020 20:58:38 +0200
-Subject: [PATCH] Build fix for GCC 10+ (-fno-common default)
-
-See https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
----
- Simulator/input/read.c | 7 +++++++
- Simulator/input/read.h | 10 +++++-----
- Simulator/utils/deadlock_analysis.c | 11 +++++++++++
- Simulator/utils/deadlock_analysis.h | 16 ++++++++--------
- Simulator/utils/graph.c | 3 +++
- Simulator/utils/graph.h | 4 ++--
- 6 files changed, 36 insertions(+), 15 deletions(-)
-
-diff --git a/Simulator/input/read.c b/Simulator/input/read.c
-index 2ada26e..4a62055 100644
---- a/Simulator/input/read.c
-+++ b/Simulator/input/read.c
-@@ -44,6 +44,13 @@
- #include <file_data_access.h>
- #include <schedule.h>
-
-+pthread_t reader_thread;
-+
-+volatile struct t_action ***action_buffer;
-+volatile int *buffer_heads;
-+volatile int *buffer_tails;
-+int bsize_per_thread;
-+
- struct t_Ptask *Ptask_current;
- int stop_restarts;
- extern t_boolean reload_while_longest_running;
-diff --git a/Simulator/input/read.h b/Simulator/input/read.h
-index b009524..8654ff6 100644
---- a/Simulator/input/read.h
-+++ b/Simulator/input/read.h
-@@ -3,12 +3,12 @@
-
- #include <pthread.h>
-
--pthread_t reader_thread;
-+extern pthread_t reader_thread;
-
--volatile struct t_action ***action_buffer;
--volatile int *buffer_heads;
--volatile int *buffer_tails;
--int bsize_per_thread;
-+extern volatile struct t_action ***action_buffer;
-+extern volatile int *buffer_heads;
-+extern volatile int *buffer_tails;
-+extern int bsize_per_thread;
-
- /*
- * MACROS PARA LA FUNCION 'show_individual_statistics_pallas'
-diff --git a/Simulator/utils/deadlock_analysis.c b/Simulator/utils/deadlock_analysis.c
-index e29bfe1..e1c46db 100644
---- a/Simulator/utils/deadlock_analysis.c
-+++ b/Simulator/utils/deadlock_analysis.c
-@@ -7,6 +7,17 @@
- #include <list.h>
- #include <communic.h>
-
-+struct t_estats * estats_per_rank;
-+
-+int are_estats_parsed;
-+int total_ranks;
-+char * extra_stats_filename;
-+
-+unsigned int _MAX_SENDS;
-+unsigned int _MAX_RECVS;
-+unsigned int _MAX_GLOPS;
-+
-+float _end_analysis_tpercent;
-
- int _get_earlier_task_index(int * dep_chain_queue, int deepness, t_boolean ignore_glops);
-
-diff --git a/Simulator/utils/deadlock_analysis.h b/Simulator/utils/deadlock_analysis.h
-index 4bd179b..67ca780 100644
---- a/Simulator/utils/deadlock_analysis.h
-+++ b/Simulator/utils/deadlock_analysis.h
-@@ -30,19 +30,19 @@ struct t_deadlock_descriptor
- int discarded;
- };
-
--struct t_estats * estats_per_rank;
-+extern struct t_estats * estats_per_rank;
-
--int are_estats_parsed;
--int total_ranks;
--char * extra_stats_filename;
-+extern int are_estats_parsed;
-+extern int total_ranks;
-+extern char * extra_stats_filename;
-
- // Keeps the maximum number of sends and recieves in all ranks. This info is
- // gathered through estats file.
--unsigned int _MAX_SENDS;
--unsigned int _MAX_RECVS;
--unsigned int _MAX_GLOPS;
-+extern unsigned int _MAX_SENDS;
-+extern unsigned int _MAX_RECVS;
-+extern unsigned int _MAX_GLOPS;
-
--float _end_analysis_tpercent;
-+extern float _end_analysis_tpercent;
-
-
- void DEADLOCK_init_deadlock_analysis(int ranks, const char * parameter_tracefile, float end_analysis_tpercent);
-diff --git a/Simulator/utils/graph.c b/Simulator/utils/graph.c
-index 669b818..61d138a 100644
---- a/Simulator/utils/graph.c
-+++ b/Simulator/utils/graph.c
-@@ -4,6 +4,9 @@
- #include <communic.h>
- #include <file_data_access.h>
-
-+struct dependency_queue * _graph_map;
-+int _nodes;
-+
- FILE *log_file;
- int file_index;
- char * log_file_name;
-diff --git a/Simulator/utils/graph.h b/Simulator/utils/graph.h
-index 3fc7233..6aa8c6d 100644
---- a/Simulator/utils/graph.h
-+++ b/Simulator/utils/graph.h
-@@ -52,8 +52,8 @@ struct dependency
- dimemas_timer time; // Instant when the dependency has been added
- };
-
--struct dependency_queue * _graph_map;
--int _nodes;
-+extern struct dependency_queue * _graph_map;
-+extern int _nodes;
-
-
- void GRAPH_init(int _nodes);
---
-2.26.2
-