summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLyr-7D1h2020-11-03 15:05:48 +0100
committerLyr-7D1h2020-11-03 15:05:48 +0100
commit5ac6aa8b5c881a90e5a569db544bc68ce495008b (patch)
treed9211cfec050bfcd17fee0f258130f93977e5e6e
downloadaur-5ac6aa8b5c881a90e5a569db544bc68ce495008b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--dimportd.service13
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eddb96ad5b01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dimport
+ pkgdesc = Dotfiles Importer - Import and keep your dotfiles in sync
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/Lyr-7D1h/dotfiles_importer_revamped
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ depends = dbus
+ source = git+https://github.com/Lyr-7D1h/dotfiles_importer_revamped.git#tag=v1.3?signed
+ source = dimportd.service
+ validpgpkeys = F0E576DC4C752710F168C87C650AC1B95E7FEE6E
+ sha256sums = SKIP
+ sha256sums = ae52ae32a5e92f4c90ffe524ba5cccd25b3d9fe11557106127c4e56bdfdef3b4
+
+pkgname = dimport
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dbe5099a3c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Lyr <lyr-7d1h@pm.me>
+
+pkgname="dimport"
+pkgver=1.3
+pkgrel=1
+pkgdesc="Dotfiles Importer - Import and keep your dotfiles in sync"
+arch=("x86_64")
+url="https://github.com/Lyr-7D1h/dotfiles_importer_revamped"
+license=("MIT")
+depends=("dbus")
+makedepends=("rust" "cargo")
+source=("git+https://github.com/Lyr-7D1h/dotfiles_importer_revamped.git#tag=v${pkgver}?signed"
+ "dimportd.service")
+validpgpkeys=("F0E576DC4C752710F168C87C650AC1B95E7FEE6E")
+sha256sums=('SKIP'
+ 'ae52ae32a5e92f4c90ffe524ba5cccd25b3d9fe11557106127c4e56bdfdef3b4')
+
+build() {
+ cd "$srcdir/dotfiles_importer_revamped/dimport"
+ SOCKET_PATH=/run/dimportd.socket \
+ cargo build --release --locked
+ cd "$srcdir/dotfiles_importer_revamped/dimportd"
+ SOCKET_PATH=/run/dimportd.socket \
+ CONFIG_PATH=/etc/dimport/config.json \
+ STATE_PATH=/var/lib/dimport/state.json \
+ REPISTORY_DIR=/var/lib/dimport/repository \
+ BACKUP_DIR=/var/lib/dimport/backup \
+ cargo build --release --locked
+}
+
+package() {
+ install -D -m755 "$srcdir/dotfiles_importer_revamped/dimport/target/release/dimport" "$pkgdir/usr/bin/dimport"
+ install -D -m755 "$srcdir/dotfiles_importer_revamped/dimportd/target/release/dimportd" "$pkgdir/usr/bin/dimportd"
+ install -D -m644 "$srcdir/dotfiles_importer_revamped/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "$srcdir/dimportd.service" "$pkgdir/usr/lib/systemd/system/dimportd.service"
+ mkdir -p "$pkgdir/etc/dimport"
+ mkdir -p "$pkgdir/var/lib/dimport"
+}
diff --git a/dimportd.service b/dimportd.service
new file mode 100644
index 000000000000..87fc36660746
--- /dev/null
+++ b/dimportd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Dotfiles Import Deamon
+
+[Service]
+Environment=RUST_LOG=info
+ExecStart=/usr/sbin/dimportd
+NonBlocking=true
+KillMode=process
+Restart=on-failure
+RestartSec=5
+
+[Install]
+WantedBy=default.target \ No newline at end of file