summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLyr-7D1h2020-11-03 20:06:36 +0100
committerLyr-7D1h2020-11-05 17:21:23 +0100
commitae4267d8ebfbc92b244869c0612a3f4cce27e748 (patch)
tree4f856ad1c747184f4e204a21838a62978ffacd89
parent5ac6aa8b5c881a90e5a569db544bc68ce495008b (diff)
downloadaur-ae4267d8ebfbc92b244869c0612a3f4cce27e748.tar.gz
Version 1.4
made everything local Updated srcinfo Updated srcinfo Version 1.5 Version 1.5.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--dimportd@.service (renamed from dimportd.service)1
3 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eddb96ad5b01..f03f4d0fc7ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dimport
pkgdesc = Dotfiles Importer - Import and keep your dotfiles in sync
- pkgver = 1.3
+ pkgver = 1.5.1
pkgrel = 1
url = https://github.com/Lyr-7D1h/dotfiles_importer_revamped
arch = x86_64
@@ -8,11 +8,11 @@ pkgbase = dimport
makedepends = rust
makedepends = cargo
depends = dbus
- source = git+https://github.com/Lyr-7D1h/dotfiles_importer_revamped.git#tag=v1.3?signed
- source = dimportd.service
+ source = git+https://github.com/Lyr-7D1h/dotfiles_importer_revamped.git#tag=v1.5.1?signed
+ source = dimportd@.service
validpgpkeys = F0E576DC4C752710F168C87C650AC1B95E7FEE6E
sha256sums = SKIP
- sha256sums = ae52ae32a5e92f4c90ffe524ba5cccd25b3d9fe11557106127c4e56bdfdef3b4
+ sha256sums = 33dc92cb906bb24f7ffc019b3592d7f9ff5ae80eee841c1d9e1129b1cc5dcb77
pkgname = dimport
diff --git a/PKGBUILD b/PKGBUILD
index 5dbe5099a3c0..3ab5cffca302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lyr <lyr-7d1h@pm.me>
pkgname="dimport"
-pkgver=1.3
+pkgver=1.5.1
pkgrel=1
pkgdesc="Dotfiles Importer - Import and keep your dotfiles in sync"
arch=("x86_64")
@@ -10,21 +10,21 @@ license=("MIT")
depends=("dbus")
makedepends=("rust" "cargo")
source=("git+https://github.com/Lyr-7D1h/dotfiles_importer_revamped.git#tag=v${pkgver}?signed"
- "dimportd.service")
+ "dimportd@.service")
validpgpkeys=("F0E576DC4C752710F168C87C650AC1B95E7FEE6E")
sha256sums=('SKIP'
- 'ae52ae32a5e92f4c90ffe524ba5cccd25b3d9fe11557106127c4e56bdfdef3b4')
+ '33dc92cb906bb24f7ffc019b3592d7f9ff5ae80eee841c1d9e1129b1cc5dcb77')
build() {
cd "$srcdir/dotfiles_importer_revamped/dimport"
- SOCKET_PATH=/run/dimportd.socket \
+ SOCKET_PATH=/tmp/dimportd.socket \
cargo build --release --locked
cd "$srcdir/dotfiles_importer_revamped/dimportd"
- SOCKET_PATH=/run/dimportd.socket \
- CONFIG_PATH=/etc/dimport/config.json \
- STATE_PATH=/var/lib/dimport/state.json \
- REPISTORY_DIR=/var/lib/dimport/repository \
- BACKUP_DIR=/var/lib/dimport/backup \
+ SOCKET_PATH=/tmp/dimportd.socket \
+ CONFIG_PATH=~/.config/dimport/config.json \
+ STATE_PATH=~/.local/share/dimport/state.json \
+ REPOSITORY_DIR=~/.local/share/dimport/repository \
+ BACKUP_DIR=~/.local/share/dimport/backup \
cargo build --release --locked
}
@@ -32,7 +32,5 @@ package() {
install -D -m755 "$srcdir/dotfiles_importer_revamped/dimport/target/release/dimport" "$pkgdir/usr/bin/dimport"
install -D -m755 "$srcdir/dotfiles_importer_revamped/dimportd/target/release/dimportd" "$pkgdir/usr/bin/dimportd"
install -D -m644 "$srcdir/dotfiles_importer_revamped/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 "$srcdir/dimportd.service" "$pkgdir/usr/lib/systemd/system/dimportd.service"
- mkdir -p "$pkgdir/etc/dimport"
- mkdir -p "$pkgdir/var/lib/dimport"
+ install -D -m644 "$srcdir/dimportd@.service" "$pkgdir/usr/lib/systemd/system/dimportd@.service"
}
diff --git a/dimportd.service b/dimportd@.service
index 87fc36660746..716ba7a6ed94 100644
--- a/dimportd.service
+++ b/dimportd@.service
@@ -2,6 +2,7 @@
Description=Dotfiles Import Deamon
[Service]
+User=%i
Environment=RUST_LOG=info
ExecStart=/usr/sbin/dimportd
NonBlocking=true