summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:36:12 +0200
committerStefan Husmann2015-06-08 20:36:12 +0200
commit87f5be09d71c992570a93fd08d5c991b8e330f1b (patch)
tree4b291e54075d589a158197e70e1d8f96c6deafea
downloadaur-87f5be09d71c992570a93fd08d5c991b8e330f1b.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..436c4670a3b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ding
+ pkgdesc = A Dictionary Lookup program and EN<->DE Dictionary
+ pkgver = 1.8
+ pkgrel = 1
+ url = http://www-user.tu-chemnitz.de/~fri/ding
+ arch = any
+ license = GPL
+ depends = sh
+ depends = tk
+ depends = tre
+ depends = aspell
+ source = http://ftp.tu-chemnitz.de/pub/Local/urz/ding/ding-1.8.tar.gz
+ md5sums = 93ce724031f57efe43bd0197dbb3800c
+
+pkgname = ding
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e4a4d3e467b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Heiko Baums <heiko@baums-on-web.de>
+# Contributor: Roman Kreisel <roman.kreisel@epost.de>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=ding
+pkgver=1.8
+pkgrel=1
+pkgdesc="A Dictionary Lookup program and EN<->DE Dictionary"
+arch=('any')
+license=('GPL')
+url="http://www-user.tu-chemnitz.de/~fri/ding"
+depends=('sh' 'tk' 'tre' 'aspell')
+source=(http://ftp.tu-chemnitz.de/pub/Local/urz/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('93ce724031f57efe43bd0197dbb3800c')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -m755 -d "${pkgdir}/usr/bin"
+ install -m755 -d "${pkgdir}/usr/share/dict"
+ install -m755 -d "${pkgdir}/usr/share/man/man1"
+ install -m755 -d "${pkgdir}/usr/share/applications"
+ install -m755 -d "${pkgdir}/usr/share/pixmaps"
+
+ sed -i -e 's/ger-en.txt/de-en.txt/g' ding
+
+ install -m755 ding "${pkgdir}/usr/bin/"
+ install -m644 ding.1 "${pkgdir}/usr/share/man/man1/"
+ install -m644 de-en.txt "${pkgdir}/usr/share/dict/"
+ install -m644 ding.png "${pkgdir}/usr/share/pixmaps/"
+ install -m644 ding.desktop "${pkgdir}/usr/share/applications/"
+}