summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2020-01-29 20:22:23 -0500
committerJean Lucas2020-01-29 20:22:23 -0500
commitb13b7abaf7b0d8f562cc852a6d147b502cf6f851 (patch)
treed181cf5939c93a22348aba919f94a9d1c0bdeaec
parentb29ed8b336b85ddc1affa13b50cb0299a75c3355 (diff)
downloadaur-b13b7abaf7b0d8f562cc852a6d147b502cf6f851.tar.gz
0.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bda34f133329..83644af2f576 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = dino
pkgdesc = Modern XMPP (Jabber) chat client written in GTK+/Vala
- pkgver = 0.0+r562+g388cc56
+ pkgver = 0.1.0
pkgrel = 1
url = https://dino.im
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
makedepends = ninja
makedepends = vala
+ makedepends = libsignal-protocol-c
depends = gpgme
depends = gtk3
depends = libgee
depends = qrencode
- source = git+https://github.com/dino/dino#commit=388cc56674487e7b9e339637369fc55f0e271daf
- sha512sums = SKIP
+ optdepends = noto-fonts-emoji
+ source = dino-0.1.0.tar.gz::https://github.com/dino/dino/archive/v0.1.0.tar.gz
+ sha512sums = 4efd93f292d413ea5f602f2a861df1ff4a5e72b0a8bf93311d2d67afce0d52428c5fb9ed8dbaf9dcc604d3f1b577498018d47eb8f4a1d57e73096d83bc5067fd
pkgname = dino
diff --git a/PKGBUILD b/PKGBUILD
index b7960d31efbd..967b89c055be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,37 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=dino
-pkgver=0.0+r562+g388cc56
-_commit=388cc56674487e7b9e339637369fc55f0e271daf
+pkgver=0.1.0
pkgrel=1
pkgdesc='Modern XMPP (Jabber) chat client written in GTK+/Vala'
-arch=(i686 x86_64)
+arch=(x86_64)
url=https://dino.im
license=(GPL3)
depends=(gpgme gtk3 libgee qrencode)
-makedepends=(git cmake ninja vala)
-source=(git+https://github.com/dino/dino#commit=$_commit)
-sha512sums=('SKIP')
-
-pkgver() {
- cd dino
- git describe --tags | sed 's#-#+#g;s#+#+r#'
-}
+makedepends=(git cmake ninja vala libsignal-protocol-c)
+optdepends=(noto-fonts-emoji)
+source=(dino-$pkgver.tar.gz::https://github.com/dino/dino/archive/v$pkgver.tar.gz)
+sha512sums=('4efd93f292d413ea5f602f2a861df1ff4a5e72b0a8bf93311d2d67afce0d52428c5fb9ed8dbaf9dcc604d3f1b577498018d47eb8f4a1d57e73096d83bc5067fd')
build() {
- cd dino
+ cd dino-$pkgver
# Modify either of the following variables as desired
+ # OMEMO, OpenPGP and http-files are enabled by default
_enable=--enable-plugin='notification-sound'
#_disable=--disable-plugin='omemo;openpgp;http-files'
-
./configure --prefix=/usr --with-tests $_enable $_disable
+
make
}
check() {
- cd dino/build
+ cd dino-$pkgver/build
./xmpp-vala-test
./signal-protocol-vala-test
}
package() {
- cd dino
+ cd dino-$pkgver
make DESTDIR="$pkgdir" install
}