summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgi Kobakhidze2022-11-27 16:27:36 +0400
committerGiorgi Kobakhidze2022-11-27 16:29:09 +0400
commit694b5056b2c143d929d791103be3f95ff99b1463 (patch)
tree52fe63d09ebf3f7ff2b3baae14a489afa95e5c6a
downloadaur-694b5056b2c143d929d791103be3f95ff99b1463.tar.gz
initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD56
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cc999948de7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = dino-notification-sounds-git
+ pkgdesc = Simple and modern Jabber/XMPP client written in vala
+ pkgver = v0.3.0.r55.gcdd22e40
+ pkgrel = 1
+ url = https://dino.im/
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = vala>=0.34
+ makedepends = ninja
+ depends = glib2>=2.38
+ depends = glib-networking
+ depends = gtk4
+ depends = gpgme
+ depends = libgee>=0.10
+ depends = libgcrypt
+ depends = libsoup3
+ depends = sqlite
+ depends = qrencode
+ depends = libsignal-protocol-c
+ depends = gspell
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugin-gtk
+ depends = webrtc-audio-processing
+ depends = libnice
+ depends = libsrtp
+ optdepends = libcanberra: audio notification support
+ provides = dino-notification-sounds-git
+ conflicts = dino-notification-sounds-git
+ source = dino::git+https://github.com/dino/dino
+ sha512sums = SKIP
+
+pkgname = dino-notification-sounds-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..845d5651b033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Giorgi Kobakhidze <gk@koba.pvt.ge>
+# Contributor: Seppia <seppia@seppio.fish>
+# Contributor: svalo <me@valo.space>
+
+pkgname=dino-notification-sounds-git
+pkgver=v0.3.0.r55.gcdd22e40
+pkgrel=1
+pkgdesc="Simple and modern Jabber/XMPP client written in vala"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://dino.im/"
+license=('GPL3')
+depends=('glib2>=2.38' 'glib-networking' 'gtk4' 'gpgme'
+ 'libgee>=0.10' 'libgcrypt' 'libsoup3' 'sqlite' 'qrencode'
+ 'libsignal-protocol-c' 'gspell' 'gst-plugins-base'
+ 'gst-plugins-good' 'gst-plugin-gtk' 'webrtc-audio-processing'
+ 'libnice' 'libsrtp')
+makedepends=('git' 'cmake' 'vala>=0.34' 'ninja')
+optdepends=('libcanberra: audio notification support')
+provides=("${pkgname%-git-notification-sounds}")
+conflicts=("${pkgname%-git-notification-sounds}")
+source=('dino::git+https://github.com/dino/dino')
+sha512sums=('SKIP')
+
+### Any or all of the following plugin can be disabled: omemo, openpgp, http-files. Populate following string as per your needs and uncomment it.
+
+# _DISABLE_PLUGINS="--disable-plugin='omemo;openpgp;http-files;ice'"
+
+### Any or all of the following plugin can be enabled: notification-sound. Populate the following string as per you needs and uncomment it.
+### Install any needed optional dependency before
+
+_ENABLE_PLUGINS="--enable-plugin='notification-sound'"
+
+### Since 55b148a0f78c1abef57c21b2a84d97cad32b2290 dino uses by default the shared libsignal library.
+# To restore the old behaviour add '--with-libsignal-in-tree' flag to configure
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ ./configure $_DISABLE_PLUGINS $_ENABLE_PLUGINS --with-tests --prefix="/usr" CC="$CC" CFLAGS="$CFLAGS" VALACFLAGS="$VALACFLAGS"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ make DESTDIR="${pkgdir}/" install
+}
+
+check() {
+ cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ echo "Executing xmpp-vala-test:"
+ build/xmpp-vala-test
+}