summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgi Kobakhidze2022-11-27 17:22:35 +0400
committerGiorgi Kobakhidze2022-11-27 17:22:35 +0400
commit940061e17c2648fa06bfa04d4f04fa4c742c55a6 (patch)
tree23787f45105cfad132011718cc02ef82ff51f754
parent694b5056b2c143d929d791103be3f95ff99b1463 (diff)
downloadaur-940061e17c2648fa06bfa04d4f04fa4c742c55a6.tar.gz
minor mistake
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 845d5651b033..05f221062a7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ depends=('glib2>=2.38' 'glib-networking' 'gtk4' 'gpgme'
'libnice' 'libsrtp')
makedepends=('git' 'cmake' 'vala>=0.34' 'ninja')
optdepends=('libcanberra: audio notification support')
-provides=("${pkgname%-git-notification-sounds}")
-conflicts=("${pkgname%-git-notification-sounds}")
+provides=("${pkgname%-notification-sounds-git}")
+conflicts=("${pkgname%-notification-sounds-git}")
source=('dino::git+https://github.com/dino/dino')
sha512sums=('SKIP')
@@ -34,23 +34,23 @@ _ENABLE_PLUGINS="--enable-plugin='notification-sound'"
# To restore the old behaviour add '--with-libsignal-in-tree' flag to configure
pkgver() {
- cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ cd "${srcdir}/${pkgname%-notification-sounds-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ cd "${srcdir}/${pkgname%-notification-sounds-git}"
./configure $_DISABLE_PLUGINS $_ENABLE_PLUGINS --with-tests --prefix="/usr" CC="$CC" CFLAGS="$CFLAGS" VALACFLAGS="$VALACFLAGS"
make
}
package() {
- cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ cd "${srcdir}/${pkgname%-notification-sounds-git}"
make DESTDIR="${pkgdir}/" install
}
check() {
- cd "${srcdir}/${pkgname%-git-notification-sounds}"
+ cd "${srcdir}/${pkgname%-notification-sounds-git}"
echo "Executing xmpp-vala-test:"
build/xmpp-vala-test
}