summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Printzell2016-01-29 21:49:08 +0100
committerDan Printzell2016-01-29 21:49:27 +0100
commit477f4e23bf43f9a47a02f6e84fd6f08c2198b730 (patch)
treed515240389c5224f15c52ce04582823c4001004d
downloadaur-477f4e23bf43f9a47a02f6e84fd6f08c2198b730.tar.gz
First commit for dinu package
Signed-off-by: Dan Printzell <xwildn00bx@gmail.com>
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3271f2ad7156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 20:49:18 UTC 2016
+pkgbase = dinu
+ pkgdesc = Launcher, file manager, one-way terminal
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/weltensturm/dinu
+ arch = i686
+ arch = x86_64
+ groups = dlang
+ license = MIT
+ makedepends = dmd
+ makedepends = git
+ makedepends = dub
+ depends = libphobos
+ provides = dinu
+ conflicts = dinu
+ options = !strip
+ source = git+https://github.com/weltensturm/dinu#tag=v1.0.2
+ source = https://github.com/weltensturm/dinu/pull/4.patch
+ sha256sums = SKIP
+ sha256sums = 252e2aca3a23508d7bb055dfccd9d83a13749fefd5e02affa759158e2861819c
+
+pkgname = dinu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0228d3a30d9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Dan Printzell <xwildn00bx@gmail.com>
+
+pkgname=("dinu")
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Launcher, file manager, one-way terminal"
+arch=("i686" "x86_64")
+url="https://github.com/weltensturm/dinu"
+license=("MIT")
+groups=("dlang")
+makedepends=("dmd" "git" "dub")
+depends=("libphobos")
+provides=("dinu")
+conflicts=("dinu")
+options=("!strip")
+
+source=(
+ "git+https://github.com/weltensturm/dinu#tag=v${pkgver}"
+ "https://github.com/weltensturm/dinu/pull/4.patch"
+)
+sha256sums=(
+ "SKIP"
+ "252e2aca3a23508d7bb055dfccd9d83a13749fefd5e02affa759158e2861819c"
+)
+
+prepare() {
+ cd $srcdir/dinu
+ patch -Np1 -i $srcdir/4.patch
+}
+
+build() {
+ cd $srcdir/dinu
+ dub build --cache=local
+
+ strip ./bin/dinu
+}
+
+package() {
+ cd $srcdir/dinu
+
+ # binaries
+ mkdir -p $pkgdir/usr/bin
+ install -m755 -t $pkgdir/usr/bin ./bin/dinu
+ install -m755 -t $pkgdir/usr/bin ./complete.sh
+}