summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Printzell2016-01-29 21:52:48 +0100
committerDan Printzell2016-01-29 21:52:48 +0100
commit21ba15f40ac20e050f98a89cdd4d913531c41ade (patch)
tree71b92015c9c931ef88fdcdc186c76f9a8564688a
downloadaur-21ba15f40ac20e050f98a89cdd4d913531c41ade.tar.gz
First commit for dinu-git package
Signed-off-by: Dan Printzell <xwildn00bx@gmail.com>
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD50
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2064770fb059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 20:52:24 UTC 2016
+pkgbase = dinu-git
+ pkgdesc = Launcher, file manager, one-way terminal
+ pkgver = r43.9b15586
+ pkgrel = 1
+ url = https://github.com/weltensturm/dinu
+ arch = i686
+ arch = x86_64
+ groups = dlang
+ license = MIT
+ makedepends = dmd
+ makedepends = git
+ makedepends = dub
+ depends = libphobos
+ provides = dinu
+ conflicts = dinu
+ options = !strip
+ source = git+https://github.com/weltensturm/dinu
+ source = https://github.com/weltensturm/dinu/pull/4.patch
+ sha256sums = SKIP
+ sha256sums = 252e2aca3a23508d7bb055dfccd9d83a13749fefd5e02affa759158e2861819c
+
+pkgname = dinu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a90fa7418bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Dan Printzell <xwildn00bx@gmail.com>
+
+pkgname=("dinu-git")
+pkgver=r43.9b15586
+pkgrel=1
+pkgdesc="Launcher, file manager, one-way terminal"
+arch=("i686" "x86_64")
+url="https://github.com/weltensturm/dinu"
+license=("MIT")
+groups=("dlang")
+makedepends=("dmd" "git" "dub")
+depends=("libphobos")
+provides=("dinu")
+conflicts=("dinu")
+options=("!strip")
+
+source=(
+ "git+https://github.com/weltensturm/dinu"
+ "https://github.com/weltensturm/dinu/pull/4.patch"
+)
+sha256sums=(
+ "SKIP"
+ "252e2aca3a23508d7bb055dfccd9d83a13749fefd5e02affa759158e2861819c"
+)
+
+pkgver() {
+ cd $srcdir/dinu
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $srcdir/dinu
+ patch -Np1 -i $srcdir/4.patch
+}
+
+build() {
+ cd $srcdir/dinu
+ dub build --cache=local
+
+ strip ./bin/dinu
+}
+
+package() {
+ cd $srcdir/dinu
+
+ # binaries
+ mkdir -p $pkgdir/usr/bin
+ install -m755 -t $pkgdir/usr/bin ./bin/dinu
+ install -m755 -t $pkgdir/usr/bin ./complete.sh
+}