summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122020-07-02 19:34:29 +0200
committerwillemw122020-07-02 19:34:29 +0200
commitcf2148c8b87145dfd7f5f913196886f29a63ba0c (patch)
treec7b558bef35ff34faf7adcde25416007abdee1bf
parentdcb28e26e2ddfbf083fd3842e750a176d8c0d9ba (diff)
downloadaur-cf2148c8b87145dfd7f5f913196886f29a63ba0c.tar.gz
Add version check patch. Enable build tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11f5344dd7b7..debe22bb0cbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = diodon-git
pkgdesc = GTK+ clipboard manager
- pkgver = 1.8.0.r12.g3b13ba0
+ pkgver = 1.10.0.r0.g3dde466
pkgrel = 1
url = https://launchpad.net/diodon
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4c6d35f736e7..e84899d72b00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=diodon-git
-pkgver=1.9.0.r0.g396cd4d
+pkgver=1.10.0.r0.g3dde466
pkgrel=1
pkgdesc="GTK+ clipboard manager"
arch=('x86_64')
@@ -9,9 +9,9 @@ url="https://launchpad.net/diodon"
license=('GPL2')
depends=('gobject-introspection' 'libappindicator-gtk3' 'libpeas' 'xorg-server-xvfb' 'zeitgeist')
makedepends=('cmake' 'git' 'meson' 'vala')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
-source=($pkgname::git+https://github.com/diodon-dev/diodon.git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+https://github.com/diodon-dev/diodon.git")
md5sums=('SKIP')
pkgver() {
@@ -21,9 +21,9 @@ pkgver() {
prepare() {
cd $pkgname
- # Comment out the following lines to enable the build tests
- rm -rf tests/*
- touch tests/meson.build
+
+ # Patch version check
+ sed -i "s/appindicator_dep = dependency.*ayatana-appindicator3-0.1', version: .*/appindicator_dep = dependency('appindicator3-0.1', version: '>=0.3.0')/" meson.build
}
build() {