summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Burroughs (Celti)2016-05-20 01:11:11 -0700
committerPatrick Burroughs (Celti)2016-05-20 01:11:11 -0700
commit3ba3caa1e63bb2cd664b4d3155d5ec7d7702a6ec (patch)
treed73fc194f2e14c1f6cc6f2c121bbd8b3b386c0fd
parent138e607faa397537635b0c35a5dcf4006961c995 (diff)
downloadaur-3ba3caa1e63bb2cd664b4d3155d5ec7d7702a6ec.tar.gz
upgpkg: diorite-git 0.2.0.r20.g885d3e6-2
upgpkg: nuvolaplayer-git 3.0.0.r33.ge32cb1e-1 upstream release diorite/nuvolaplayer: cleanup, fix deps
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8f11eb8b50d..74cf9e458eff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Apr 13 19:42:32 UTC 2016
+# Fri May 20 08:11:12 UTC 2016
pkgbase = diorite-git
pkgdesc = Utility and widget library based on Glib and GTK3.
pkgver = 0.2.0.r20.g885d3e6
- pkgrel = 1
- url = https://tiliado.eu/diorite
+ pkgrel = 2
+ url = https://tiliado.eu/diorite/
arch = i686
arch = x86_64
license = GPL
makedepends = git
- depends = python
- depends = vala
- depends = glib2
+ makedepends = python
+ makedepends = vala
depends = gtk3
- source = diorite-git::git://github.com/tiliado/diorite
+ optdepends = python: For generating tests.
+ source = diorite-git::git+https://github.com/tiliado/diorite
sha256sums = SKIP
pkgname = diorite-git
diff --git a/PKGBUILD b/PKGBUILD
index 8f840e72b974..8cf07a6357cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,29 @@
pkgname=diorite-git
pkgver=0.2.0.r20.g885d3e6
-pkgrel=1
-pkgdesc="Utility and widget library based on Glib and GTK3."
+pkgrel=2
+pkgdesc='Utility and widget library based on Glib and GTK3.'
arch=('i686' 'x86_64')
-url="https://tiliado.eu/diorite"
+url='https://tiliado.eu/diorite/'
license=('GPL')
-makedepends=('git')
-depends=('python' 'vala' 'glib2' 'gtk3')
-source=("$pkgname::git://github.com/tiliado/diorite")
+makedepends=('git' 'python' 'vala')
+depends=('gtk3')
+optdepends=('python: For generating tests.')
+source=("$pkgname::git+https://github.com/tiliado/diorite")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- ./waf configure --prefix=/usr
- ./waf build
+ cd "${pkgname}"
+ ./waf configure --prefix=/usr
+ ./waf build
}
package() {
- cd "$pkgname"
- ./waf install --destdir="${pkgdir}"
+ cd "${pkgname}"
+ ./waf install --destdir="${pkgdir}"
}