summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Burroughs (Celti)2015-06-09 15:46:49 -0700
committerPatrick Burroughs (Celti)2015-06-09 15:46:49 -0700
commitaee7a88f32c88c050f6deaa71ca05432e6bed667 (patch)
treec68fdfa61bdee3114545d49305f7223c70a4e25b
downloadaur-aee7a88f32c88c050f6deaa71ca05432e6bed667.tar.gz
Initial import.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a5489168c12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = diorite-git
+ pkgdesc = Utility and widget library based on Glib and GTK3.
+ pkgver = 2015.05.06.c9a04c6
+ pkgrel = 1
+ url = https://tiliado.eu/diorite
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = vala
+ depends = glib2
+ depends = gtk3
+ provides = diorite
+ source = diorite-git::git://github.com/tiliado/diorite
+ sha256sums = SKIP
+
+pkgname = diorite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11a86950862d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Patrick Burroughs (Celti) <celticmadman@gmail.com>
+# Contributor: Keerthan Jaic <jckeerthan at gmail dot com>
+
+pkgname=diorite-git
+pkgver=2015.05.06.c9a04c6
+pkgrel=1
+pkgdesc="Utility and widget library based on Glib and GTK3."
+arch=('i686' 'x86_64')
+url="https://tiliado.eu/diorite"
+license=('GPL')
+makedepends=('git')
+provides=('diorite')
+depends=('python' 'vala' 'glib2' 'gtk3')
+source=("$pkgname::git://github.com/tiliado/diorite")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --format="%cd.%h" --date=short | sed 's:-:.:g'
+}
+
+build() {
+ cd "$pkgname"
+ ./waf configure --prefix=/usr
+ ./waf build
+}
+
+package() {
+ cd "$pkgname"
+ ./waf install --destdir="${pkgdir}"
+}