summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Burroughs (Celti)2016-05-23 06:23:28 -0700
committerPatrick Burroughs (Celti)2016-05-23 06:23:28 -0700
commitccd9bec07f288ec528c5749491a83027100a5256 (patch)
tree03fe4242a522b9b0398903766d20e87e27dcb279
parent2622c3fb53303300b6aa3126ec03f3ecc0c69d5e (diff)
downloadaur-ccd9bec07f288ec528c5749491a83027100a5256.tar.gz
change PKGBUILD layout (no rebuild necessary)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74cf9e458eff..dc385ef365c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri May 20 08:11:12 UTC 2016
+# Mon May 23 13:23:29 UTC 2016
pkgbase = diorite-git
pkgdesc = Utility and widget library based on Glib and GTK3.
pkgver = 0.2.0.r20.g885d3e6
@@ -12,7 +12,7 @@ pkgbase = diorite-git
makedepends = python
makedepends = vala
depends = gtk3
- optdepends = python: For generating tests.
+ optdepends = python: For generating tests
source = diorite-git::git+https://github.com/tiliado/diorite
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8cf07a6357cf..cfb72b96456a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,19 @@
pkgname=diorite-git
pkgver=0.2.0.r20.g885d3e6
pkgrel=2
-pkgdesc='Utility and widget library based on Glib and GTK3.'
+
arch=('i686' 'x86_64')
-url='https://tiliado.eu/diorite/'
license=('GPL')
-makedepends=('git' 'python' 'vala')
-depends=('gtk3')
-optdepends=('python: For generating tests.')
+pkgdesc='Utility and widget library based on Glib and GTK3.'
+url='https://tiliado.eu/diorite/'
+
source=("$pkgname::git+https://github.com/tiliado/diorite")
sha256sums=('SKIP')
+depends=('gtk3')
+makedepends=('git' 'python' 'vala')
+optdepends=('python: For generating tests')
+
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -23,7 +26,7 @@ build() {
cd "${pkgname}"
./waf configure --prefix=/usr
./waf build
-}
+}
package() {
cd "${pkgname}"