summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortdy2017-01-20 17:28:58 -0600
committertdy2017-01-20 17:28:58 -0600
commitd06a3775d470c3f15f1e6df2a1475541905db675 (patch)
treed0e2e4d71d9c543ab66dab84821d6247d69e7e3f
parent5de12b51028256df297c4acea0f828b678d2620d (diff)
downloadaur-d06a3775d470c3f15f1e6df2a1475541905db675.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD50
2 files changed, 26 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d492d1b6dcf..ddb5c2f96787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Tue May 24 09:03:36 UTC 2016
pkgbase = diorite-git
- pkgdesc = Utility and widget library based on Glib and GTK3.
- pkgver = 0.3.0.r19.g885d3e6
+ pkgdesc = A utility and widget library for Nuvola Player project based on GLib, GIO, and GTK
+ pkgver = r316.4553a50
pkgrel = 1
- url = https://tiliado.eu/diorite/
+ url = https://tiliado.eu/diorite
arch = i686
arch = x86_64
license = GPL
@@ -12,9 +10,10 @@ pkgbase = diorite-git
makedepends = python
makedepends = vala
depends = gtk3
- optdepends = python: For generating tests
- source = diorite-git::git+https://github.com/tiliado/diorite
- sha256sums = SKIP
+ provides = diorite
+ conflicts = diorite
+ source = diorite-git::git+https://github.com/tiliado/diorite.git
+ md5sums = SKIP
pkgname = diorite-git
diff --git a/PKGBUILD b/PKGBUILD
index f6deedb3d129..c7d3333aec5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,31 @@
-# Maintainer: Patrick Burroughs (Celti) <celti@celti.name>
-
-# Unofficial repository (x86_64 and i686) available:
-# Build scripts at: https://repo.celti.name/nuvolaplayer/
-#
-# # Both the packages and the database are signed:
-# # `pacman-key --recv-keys 123C3F8B058A707F86643316FA682BD8910CF4EA`
-# # `pacman-key --lsign-key 123C3F8B058A707F86643316FA682BD8910CF4EA`
-# [nuvolaplayer]
-# SigLevel = Required TrustedOnly
-# Server = https://repo.celti.name/archlinux/$repo/$arch
+# Maintainer: archlinux.info:tdy
pkgname=diorite-git
-pkgver=0.3.0.r19.g885d3e6
+pkgver=r316.4553a50
pkgrel=1
-
-arch=('i686' 'x86_64')
-license=('GPL')
-pkgdesc='Utility and widget library based on Glib and GTK3.'
-url='https://tiliado.eu/diorite/'
-
-source=("$pkgname::git+https://github.com/tiliado/diorite")
-sha256sums=('SKIP')
-
-depends=('gtk3')
-makedepends=('git' 'python' 'vala')
-optdepends=('python: For generating tests')
+pkgdesc="A utility and widget library for Nuvola Player project based on GLib, GIO, and GTK"
+arch=(i686 x86_64)
+url=https://tiliado.eu/diorite
+license=(GPL)
+depends=(gtk3)
+makedepends=(git python vala)
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+source=($pkgname::git+https://github.com/tiliado/${pkgname/-/.})
+md5sums=(SKIP)
pkgver() {
- cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${pkgname}"
- ./waf configure --prefix=/usr
- ./waf build
+ cd $pkgname
+ python waf configure --prefix=/usr
+ python waf build
}
package() {
- cd "${pkgname}"
- ./waf install --destdir="${pkgdir}"
+ cd $pkgname
+ python waf install --destdir="$pkgdir"
}