summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2019-04-17 13:44:52 +0200
committerSebastiaan Lokhorst2019-04-17 13:44:52 +0200
commitb0683117ffe26554aa3e27a3be19177f8b9a1600 (patch)
tree816e23794cb6efe67efeea221abad0cdfb7176f3
downloadaur-b0683117ffe26554aa3e27a3be19177f8b9a1600.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD50
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4acc29ea48d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = diplib-git
+ pkgdesc = Quantitative Image Analysis in C++, MATLAB and Python
+ pkgver = r1522.37b06c70
+ pkgrel = 1
+ url = http://www.diplib.org/
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = git
+ depends = freeglut
+ depends = glfw
+ depends = glew
+ optdepends = java-runtime=8: DIPjavaio
+ optdepends = python: PyDIP
+ optdepends = matlab: DIPimage
+ optdepends = doxygen: documentation
+ optdepends = pandoc: documentation
+ optdepends = pandoc-crossref: documentation
+ optdepends = texlive-bin: documentation
+ provides = diplib
+ conflicts = diplib
+ source = git+https://github.com/DIPlib/diplib.git
+ md5sums = SKIP
+
+pkgname = diplib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c13f588c6130
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+
+_pkgname=diplib
+pkgname="${_pkgname}-git"
+pkgver=r1522.37b06c70
+pkgrel=1
+pkgdesc='Quantitative Image Analysis in C++, MATLAB and Python'
+arch=('x86_64')
+url='http://www.diplib.org/'
+license=('Apache')
+depends=('freeglut' 'glfw' 'glew')
+makedepends=('cmake' 'git')
+optdepends=('java-runtime=8: DIPjavaio'
+ 'python: PyDIP'
+ 'matlab: DIPimage'
+ 'doxygen: documentation'
+ 'pandoc: documentation'
+ 'pandoc-crossref: documentation'
+ 'texlive-bin: documentation')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=('git+https://github.com/DIPlib/diplib.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build
+ cd build
+ cmake \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}/build"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/build"
+ make DESTDIR="${pkgdir}" install
+}