aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Smith2019-05-05 15:37:21 -0600
committerAdrien Smith2019-05-05 15:37:21 -0600
commit22774f823f22b61275d7fd3c0a12d20c1c7b3832 (patch)
tree156398bad0a9b78c99de88554a634c1f9e9a5d3e
parentce05b2cc0e8cf31fee3e7de8cd4cb1f90c9dc13f (diff)
downloadaur-22774f823f22b61275d7fd3c0a12d20c1c7b3832.tar.gz
Use Docker or Vagrant to update checksums
-rw-r--r--Dockerfile2
-rw-r--r--README.md9
-rwxr-xr-xdocker-srcinfo3
3 files changed, 7 insertions, 7 deletions
diff --git a/Dockerfile b/Dockerfile
index fef5d46541e3..89f55c0bad57 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -1,5 +1,5 @@
FROM archlinux/base:latest
-RUN pacman -Syu --noconfirm --needed base-devel
+RUN pacman -Syu --noconfirm --needed base-devel pacman-contrib
WORKDIR /src
diff --git a/README.md b/README.md
index c85ae428c3d3..f11ead835615 100644
--- a/README.md
+++ b/README.md
@@ -6,10 +6,8 @@ How to update the package from Arch on any system:
1. Edit the PKGBUILD and change the `pkgver` field.
2. If you're on Arch, run `updpkgsums && makepkg --printsrcinfo > .SRCINFO`, and skip to the last step.
-3. Download the release tar.gz and run sha256sum on it.
-4. Update the `sha256sums` field in the PKGBUILD.
-5. Use the Docker or Vagrant options below to update .SRCINFO.
-6. Commit & push
+3. If you're on a different system, use the Docker or Vagrant options below to update the checksums and .SRCINFO.
+4. Commit & push
### Docker setup
@@ -24,8 +22,9 @@ Install [Vagrant](https://www.vagrantup.com), then run the following:
vagrant up
vagrant ssh
# Install dev dependencies
-sudo pacman -Syu --needed base-devel
+sudo pacman -Syu --needed base-devel pacman-contrib
cd /vagrant
+updpkgsums
makepkg --printsrcinfo > .SRCINFO
```
diff --git a/docker-srcinfo b/docker-srcinfo
index 4f63bafd5deb..e2c6931cdc56 100755
--- a/docker-srcinfo
+++ b/docker-srcinfo
@@ -5,4 +5,5 @@
#
id=$(docker build -q .)
-docker run --rm --volume "$(pwd):/src" --user="$(id -u):$(id -g)" "$id" makepkg --printsrcinfo > .SRCINFO
+docker run --rm --volume "$(pwd):/src" --user="$(id -u):$(id -g)" "$id" \
+ /bin/bash -c 'updpkgsums && makepkg --printsrcinfo > .SRCINFO'