aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Smith2019-05-01 19:50:10 -0600
committerAdrien Smith2019-05-04 12:23:01 -0600
commita8fc2e78a618b222ed2b7eb84d85ebfa369455a7 (patch)
treefe5dfd563fd96da8b00a57dd268c09ce016dc179
parent343f9b0c45cb001dbc715ec5a4328a6557ffda00 (diff)
downloadaur-a8fc2e78a618b222ed2b7eb84d85ebfa369455a7.tar.gz
Tidy readme and update instructions
-rw-r--r--README.md21
1 files changed, 11 insertions, 10 deletions
diff --git a/README.md b/README.md
index e46c5377da21..f8122822cc59 100644
--- a/README.md
+++ b/README.md
@@ -2,28 +2,29 @@
## Package updates
-How to update the package from Arch on any system
+How to update the package from Arch on any system:
-0. Download the release tar.gz and run sha256sum on it.
-1. Edit PKGBUILD and change the `pkgver` and `sha256sums` fields.
-2. Run `mksrcinfo` (see below if you're not on Arch)
-3. Commit & push
+1. Edit the PKGBUILD and change the `pkgver` field.
+2. If you're on Arch, run `updpkgsums && makepkg --printsrcinfo > .SRCINFO`, and skip to the last step.
+3. Download the release tar.gz and run sha256sum on it.
+4. Update the `sha256sums` field in the PKGBUILD.
+5. Use the Docker or Vagrant options below to update .SRCINFO.
+6. Commit & push
### Docker setup
-Install [Docker](http://docker.com) then run `./docker-mksrcinfo`.
+Install [Docker](https://www.docker.com), then run `./docker-srcinfo`.
### Vagrant setup
-Install [Vagrant](http://vagrantup.com) then
+Install [Vagrant](https://www.vagrantup.com), then run the following:
```bash
# Create vagrant box
vagrant up
vagrant ssh
# Install dev dependencies
-sudo pacman -Syu
-sudo pacman -S --needed base-devel
+sudo pacman -Syu --needed base-devel
cd /vagrant
makepkg --printsrcinfo > .SRCINFO
```
@@ -31,7 +32,7 @@ makepkg --printsrcinfo > .SRCINFO
## Push to multiple origins
```bash
-git clone ssh+git://aur@aur4.archlinux.org/direnv.git/ direnv-archlinux
+git clone ssh://aur@aur.archlinux.org/direnv.git direnv-archlinux
cd direnv-archlinux
git remote set-url --add github https://github.com/direnv/direnv-archlinux.git
```