summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2017-03-09 21:22:00 +0100
committerAlexander Fasching2017-03-09 21:30:39 +0100
commitecf859c213726f3914b2a5ec9b5bec5d8d8a12ba (patch)
tree807b9cb27236b219ff41f3171a17a770fa2579f3
downloadaur-ecf859c213726f3914b2a5ec9b5bec5d8d8a12ba.tar.gz
Initial package version
-rw-r--r--.SRCINFO32
-rw-r--r--Makefile.patch20
-rw-r--r--PKGBUILD59
-rw-r--r--direwolf-kiss.service10
-rw-r--r--direwolf.service10
5 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..503f2e9f8e64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = direwolf-git
+ pkgdesc = Dire Wolf is a software modem/TNC and APRS encoder/decoder
+ pkgver = 1.3.r2.g6207e2e
+ pkgrel = 1
+ url = https://github.com/wb2osz/direwolf
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = make
+ makedepends = gcc
+ makedepends = patch
+ depends = alsa-lib
+ depends = gpsd
+ provides = direwolf
+ conflicts = direwolf
+ source = git+https://github.com/wb2osz/direwolf.git
+ source = Makefile.patch
+ source = direwolf.service
+ source = direwolf-kiss.service
+ sha1sums = SKIP
+ sha1sums = f94b193a8e49bae073de3cedff4394821d6148fa
+ sha1sums = 66366c7a4e8d3768013f9036f2681a86d4b8ad88
+ sha1sums = eea3a3fb334645cd8a1e2604dc6c6b024148722a
+ sha256sums = SKIP
+ sha256sums = 5a4bee3543da1bbe9cd8bd5edb3bb9b502728841c4c34da332a19f34f876a140
+ sha256sums = a1efe2bb96470bc52faa747708b195a685dc454f3d9c91f6bf4d39ab94d3608a
+ sha256sums = 2a2e4acc769a20afebdfdcd21640fd17b0c4217ceb7ecb3378f9ee5c45fadc68
+
+pkgname = direwolf-git
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..6c34dfb8accb
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,20 @@
+diff -Nurd direwolf-1.3.orig/Makefile.linux direwolf-1.3/Makefile.linux
+--- direwolf-1.3.orig/Makefile.linux 2016-05-03 00:08:29.000000000 +0000
++++ direwolf-1.3/Makefile.linux 2016-10-18 20:56:54.709562096 +0000
+@@ -490,11 +490,11 @@
+ #
+ # Misc. data such as "tocall" to system mapping.
+ #
+- $(INSTALL) -D --mode=644 tocalls.txt /usr/share/direwolf/tocalls.txt
+- $(INSTALL) -D --mode=644 symbols-new.txt /usr/share/direwolf/symbols-new.txt
+- $(INSTALL) -D --mode=644 symbolsX.txt /usr/share/direwolf/symbolsX.txt
+- $(INSTALL) -D --mode=644 dw-icon.png /usr/share/direwolf/dw-icon.png
+- $(INSTALL) -D --mode=644 direwolf.desktop /usr/share/applications/direwolf.desktop
++ $(INSTALL) -D --mode=644 tocalls.txt $(INSTALLDIR)/share/direwolf/tocalls.txt
++ $(INSTALL) -D --mode=644 symbols-new.txt $(INSTALLDIR)/share/direwolf/symbols-new.txt
++ $(INSTALL) -D --mode=644 symbolsX.txt $(INSTALLDIR)/share/direwolf/symbolsX.txt
++ $(INSTALL) -D --mode=644 dw-icon.png $(INSTALLDIR)/share/direwolf/dw-icon.png
++ $(INSTALL) -D --mode=644 direwolf.desktop $(INSTALLDIR)/share/applications/direwolf.desktop
+ #
+ # Documentation. Various plain text files and PDF.
+ #
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68c57d64f5a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Alexander Fasching <fasching.a91@gmail.com>
+pkgname=direwolf-git
+_pkgname=direwolf
+pkgver=1.3.r2.g6207e2e
+pkgrel=1
+pkgdesc="Dire Wolf is a software modem/TNC and APRS encoder/decoder"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/wb2osz/direwolf"
+license=('GPL')
+depends=('alsa-lib' 'gpsd')
+makedepends=('make' 'gcc' 'patch')
+provides=('direwolf')
+conflicts=('direwolf')
+source=("git+https://github.com/wb2osz/direwolf.git"
+ 'Makefile.patch'
+ 'direwolf.service'
+ 'direwolf-kiss.service')
+sha1sums=('SKIP'
+ 'f94b193a8e49bae073de3cedff4394821d6148fa'
+ '66366c7a4e8d3768013f9036f2681a86d4b8ad88'
+ 'eea3a3fb334645cd8a1e2604dc6c6b024148722a')
+sha256sums=('SKIP'
+ '5a4bee3543da1bbe9cd8bd5edb3bb9b502728841c4c34da332a19f34f876a140'
+ 'a1efe2bb96470bc52faa747708b195a685dc454f3d9c91f6bf4d39ab94d3608a'
+ '2a2e4acc769a20afebdfdcd21640fd17b0c4217ceb7ecb3378f9ee5c45fadc68')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ patch -p1 < ../Makefile.patch
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+check() {
+ :
+}
+
+package() {
+ cd "$_pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/doc/$_pkgname"
+ mkdir -p "$pkgdir/var/log/direwolf"
+ make INSTALLDIR="$pkgdir/usr" install
+
+ mkdir -p "$pkgdir/etc/direwolf"
+ install -D -m 644 direwolf.conf "$pkgdir/etc/direwolf/direwolf.conf"
+
+ mkdir -p "$pkgdir/usr/lib/systemd/system"
+ install -D -m 644 ../direwolf.service "$pkgdir/usr/lib/systemd/system"
+ install -D -m 644 ../direwolf-kiss.service "$pkgdir/usr/lib/systemd/system"
+}
diff --git a/direwolf-kiss.service b/direwolf-kiss.service
new file mode 100644
index 000000000000..473feb246c31
--- /dev/null
+++ b/direwolf-kiss.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Dire Wolf
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/direwolf -l /var/log/direwolf -p
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/direwolf.service b/direwolf.service
new file mode 100644
index 000000000000..47eb3e7871bb
--- /dev/null
+++ b/direwolf.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Dire Wolf
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/direwolf -l /var/log/direwolf
+Restart=always
+
+[Install]
+WantedBy=multi-user.target