summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2018-02-08 18:08:48 +0100
committerAlexander Fasching2018-02-08 18:08:48 +0100
commited0bceb4c03f67d5a700ae8854655a6f2bbbaa70 (patch)
tree2e705a62090f350c926421b57352ebcbfac67440
parent4f87f4da88e2edd8d4867f7675c41c296611c379 (diff)
downloadaur-ed0bceb4c03f67d5a700ae8854655a6f2bbbaa70.tar.gz
Update Makefile.patch to new upstream
-rw-r--r--Makefile.patch33
-rw-r--r--PKGBUILD17
2 files changed, 20 insertions, 30 deletions
diff --git a/Makefile.patch b/Makefile.patch
index 6c34dfb8accb..f6c110091f1e 100644
--- a/Makefile.patch
+++ b/Makefile.patch
@@ -1,20 +1,13 @@
-diff -Nurd direwolf-1.3.orig/Makefile.linux direwolf-1.3/Makefile.linux
---- direwolf-1.3.orig/Makefile.linux 2016-05-03 00:08:29.000000000 +0000
-+++ direwolf-1.3/Makefile.linux 2016-10-18 20:56:54.709562096 +0000
-@@ -490,11 +490,11 @@
- #
- # Misc. data such as "tocall" to system mapping.
- #
-- $(INSTALL) -D --mode=644 tocalls.txt /usr/share/direwolf/tocalls.txt
-- $(INSTALL) -D --mode=644 symbols-new.txt /usr/share/direwolf/symbols-new.txt
-- $(INSTALL) -D --mode=644 symbolsX.txt /usr/share/direwolf/symbolsX.txt
-- $(INSTALL) -D --mode=644 dw-icon.png /usr/share/direwolf/dw-icon.png
-- $(INSTALL) -D --mode=644 direwolf.desktop /usr/share/applications/direwolf.desktop
-+ $(INSTALL) -D --mode=644 tocalls.txt $(INSTALLDIR)/share/direwolf/tocalls.txt
-+ $(INSTALL) -D --mode=644 symbols-new.txt $(INSTALLDIR)/share/direwolf/symbols-new.txt
-+ $(INSTALL) -D --mode=644 symbolsX.txt $(INSTALLDIR)/share/direwolf/symbolsX.txt
-+ $(INSTALL) -D --mode=644 dw-icon.png $(INSTALLDIR)/share/direwolf/dw-icon.png
-+ $(INSTALL) -D --mode=644 direwolf.desktop $(INSTALLDIR)/share/applications/direwolf.desktop
- #
- # Documentation. Various plain text files and PDF.
- #
+diff --git a/Makefile.linux b/Makefile.linux
+index 5010833..c7d0503 100644
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -680,7 +680,7 @@ install : $(APPS) direwolf.conf tocalls.txt symbols-new.txt symbolsX.txt dw-icon
+ # Set group and mode of HID devices corresponding to C-Media USB Audio adapters.
+ # This will allow us to use the CM108/CM119 GPIO pins for PTT.
+ #
+- $(INSTALL) -D --mode=644 99-direwolf-cmedia.rules /etc/udev/rules.d/99-direwolf-cmedia.rules
++ $(INSTALL) -D --mode=644 99-direwolf-cmedia.rules $(ROOTDIR)/etc/udev/rules.d/99-direwolf-cmedia.rules
+ #
+ @echo " "
+ @echo "If this is your first install, not an upgrade, type this to put a copy"
diff --git a/PKGBUILD b/PKGBUILD
index e6cc17830adc..61670e2bea28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Fasching <fasching.a91@gmail.com>
pkgname=direwolf-git
_pkgname=direwolf
-pkgver=1.4.dev.E.r12.gb6254da
+pkgver=1.5.beta.r3.g2328ecd
pkgrel=1
pkgdesc="Dire Wolf is a software modem/TNC and APRS encoder/decoder"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -11,19 +11,20 @@ depends=('alsa-lib' 'gpsd')
makedepends=('make' 'gcc' 'patch')
provides=('direwolf')
conflicts=('direwolf')
-source=("git+https://github.com/wb2osz/direwolf.git#branch=dev"
+source=('git+https://github.com/wb2osz/direwolf.git#branch=dev'
'Makefile.patch'
'direwolf.service'
'direwolf-kiss.service')
sha1sums=('SKIP'
- 'f94b193a8e49bae073de3cedff4394821d6148fa'
+ '8fd025e2df746a4c776c482f04ce93791aad01f6'
'66366c7a4e8d3768013f9036f2681a86d4b8ad88'
'eea3a3fb334645cd8a1e2604dc6c6b024148722a')
sha256sums=('SKIP'
- '5a4bee3543da1bbe9cd8bd5edb3bb9b502728841c4c34da332a19f34f876a140'
+ 'd3f93a6cabe348d410c630f612dd49373f9932f747588dfd915283f3167e2a48'
'a1efe2bb96470bc52faa747708b195a685dc454f3d9c91f6bf4d39ab94d3608a'
'2a2e4acc769a20afebdfdcd21640fd17b0c4217ceb7ecb3378f9ee5c45fadc68')
+
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -31,7 +32,7 @@ pkgver() {
prepare() {
cd "$_pkgname"
- patch -p1 < ../Makefile.patch
+ git apply ../Makefile.patch
}
build() {
@@ -39,16 +40,12 @@ build() {
make
}
-check() {
- :
-}
-
package() {
cd "$_pkgname"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/doc/$_pkgname"
mkdir -p "$pkgdir/var/log/direwolf"
- make INSTALLDIR="$pkgdir/usr" install
+ make DESTDIR="$pkgdir/usr" ROOTDIR="$pkgdir" install
mkdir -p "$pkgdir/etc/direwolf"
install -D -m 644 direwolf.conf "$pkgdir/etc/direwolf/direwolf.conf"