summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-05-10 16:18:51 +0200
committerKr1ss2021-05-10 16:18:51 +0200
commitc6d6f904d939a93d5b7dd586984a9aadfd3348ab (patch)
tree1811b5ada7b3586680d1afdc6de098411644bacc
parent6fac1bfccba5afdf7cc917af2fff02c5447cb11a (diff)
downloadaur-c6d6f904d939a93d5b7dd586984a9aadfd3348ab.tar.gz
update changelog
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGELOG.md9
-rw-r--r--PKGBUILD4
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 749ce748bfc9..ffe766c09895 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dirsearch-git
pkgdesc = Web path scanner/fuzzer, written in Python
- pkgver = 0.4.1.alpha_2.r0.753c7a1
+ pkgver = 0.4.1.alpha_2.r81.be2828a
pkgrel = 1
url = https://github.com/maurosoria/dirsearch
changelog = CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 066e88745095..ca9bc08486a4 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -2,14 +2,19 @@
Currently working...
---------
-- Fixed critical bugs from v0.4.1 (IMPORTANT)
+- Fixed critical bugs from v0.4.1
- Exclude responses by redirects
- URLs from STDIN
- Fixed the CSV Injection vulnerability (https://www.exploit-db.com/exploits/49370)
- Raw request supported
- Can setup the default URL scheme (will be used when there is no scheme in the URL)
-- Option to skip target by specified status codes
- Added max-runtime option
+- Recursion on specified status codes
+- Max request rate
+- Support basic authentication
+- Deep recursive scan
+- Option to force recurse on all found paths (not just the ones end with /)
+- Option to skip target by specified status codes
v0.4.1 (2020.12.8)
---------
diff --git a/PKGBUILD b/PKGBUILD
index 337cda636e0a..df181998250d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=dirsearch-git
_name="${pkgname%-git}"
pkgver() { git -C "$_name" describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\(alpha\)\([0-9]\+\)/\1_\2/'; }
-pkgver=0.4.1.alpha_2.r0.753c7a1
+pkgver=0.4.1.alpha_2.r81.be2828a
pkgrel=1
pkgdesc='Web path scanner/fuzzer, written in Python'
@@ -34,7 +34,7 @@ prepare() {
package() {
cd "$_name"
install -dm755 "$pkgdir/usr"/{bin,"lib/$_name"}
- cp -a --no-preserve=o db lib thirdparty default.conf dirsearch.py "$pkgdir/usr/lib/$_name/"
+ cp -a --no-preserve=o db lib thirdparty default.conf "$_name.py" "$pkgdir/usr/lib/$_name/"
install -Dm644 *.md -t"$pkgdir/usr/share/doc/$_name/"
ln -s "/usr/lib/$_name/$_name.py" "$pkgdir/usr/bin/$_name"
}