summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Egorov2023-09-10 13:14:44 +0300
committerAlexander Egorov2023-09-10 13:14:44 +0300
commit08c38bcb2e1ac4557c878d5836e99f57af705607 (patch)
tree590ead6e6102d6a3301b0f00cd617b07dd3ff4b3
downloadaur-08c38bcb2e1ac4557c878d5836e99f57af705607.tar.gz
dirstat 1.2.4
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f078b87ada80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dirstat-go-bin
+ pkgdesc = Small tool that shows selected folder or drive usage statistic (binary release)
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://github.com/aegoroff/dirstat
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ source_x86_64 = https://github.com/aegoroff/dirstat/releases/download/v1.2.4/dirstat_1.2.4_linux_amd64.tar.gz
+ sha256sums_x86_64 = 3da62399d6cb8a8af606bbfda97d1fe0e833b17856793707c5a7e013c43ac6e4
+ source_armv7h = https://github.com/aegoroff/dirstat/releases/download/v1.2.4/dirstat_1.2.4_linux_armv7.tar.gz
+ sha256sums_armv7h = 5e895f4b7b0f9429492b230fc456a7b49646281824c1cc8a5bde3280a98f32d7
+ source_aarch64 = https://github.com/aegoroff/dirstat/releases/download/v1.2.4/dirstat_1.2.4_linux_arm64.tar.gz
+ sha256sums_aarch64 = 2a7d6a5cef9beeb65f7dc6c94a20ef4d43be871fc84e79efca5d1ab6ccbd90d2
+
+pkgname = dirstat-go-bin
+ provides = dirstat-go-bin
+ conflicts = dirstat-bin
+ conflicts = dirstat-go-bin
+ conflicts = dirstat-go
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc4348bd47f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: egoroff <egoroff@gmail.com>
+pkgname=dirstat-go-bin
+pkgver=1.2.4
+pkgrel=1
+arch=('x86_64' 'armv7h' 'aarch64')
+pkgdesc="Small tool that shows selected folder or drive usage statistic (binary release)"
+url="https://github.com/aegoroff/dirstat"
+license=('Apache')
+source_x86_64=("https://github.com/aegoroff/dirstat/releases/download/v${pkgver}/dirstat_${pkgver}_linux_amd64.tar.gz")
+source_armv7h=("https://github.com/aegoroff/dirstat/releases/download/v${pkgver}/dirstat_${pkgver}_linux_armv7.tar.gz")
+source_aarch64=("https://github.com/aegoroff/dirstat/releases/download/v${pkgver}/dirstat_${pkgver}_linux_arm64.tar.gz")
+sha256sums_x86_64=('3da62399d6cb8a8af606bbfda97d1fe0e833b17856793707c5a7e013c43ac6e4')
+sha256sums_armv7h=('5e895f4b7b0f9429492b230fc456a7b49646281824c1cc8a5bde3280a98f32d7')
+sha256sums_aarch64=('2a7d6a5cef9beeb65f7dc6c94a20ef4d43be871fc84e79efca5d1ab6ccbd90d2')
+
+build() {
+ return 0
+}
+
+package() {
+ provides=("dirstat-go-bin")
+ conflicts=("dirstat-bin" "dirstat-go-bin" "dirstat-go")
+
+ install -Dm0755 "dirstat" "$pkgdir/usr/bin/dirstat"
+ install -Dm0755 "LICENSE.txt" "$pkgdir/usr/share/licenses/dirstat/LICENSE.txt"
+ install -Dm0755 "README.md" "$pkgdir/usr/share/doc/dirstat/README.md"
+}